: W4M Exhaust



GPat599
08-01-09, 08:07 PM
I just got Jesse's W4M 3'' exhaust and I'm having trouble getting the exhaust to line up straight coming out of the back of the car. I tried bending the stock hangers over to pull the tail pipes over but they just slowly bend them back into a crooked position again. I also am wondering about the ground clearance, to me it seems the pipes hang really low.

I am just wondering if anyone else has ran into these problems and what they did to fix them.

--Despite this minor inconvenience, I am extremely pleased with Jesse's exhaust. The sound is ferociously incredible and the added horsepower is awesome, really noticeable, especially in the low end torque range. Therefore, I am hoping to get these issues resolved so it can be perfect.

wait4me
08-01-09, 10:01 PM
There shouldn't be any ground clearance issues, if you can snap some photos of it, that would be great. I hand fit each one on the car as i make them so they always should fit nice and snug to the frame, Usually it is just a photo shot away from me telling you where you need to move something I have seen where it was put in upside down on the front piece making it out of whack. Jessebubb@yahoo.com

Maybe possible that something got bent in shipping, I can always just ship out another piece to try.

GPat599
08-02-09, 03:11 AM
There shouldn't be any ground clearance issues, if you can snap some photos of it, that would be great. I hand fit each one on the car as i make them so they always should fit nice and snug to the frame, Usually it is just a photo shot away from me telling you where you need to move something I have seen where it was put in upside down on the front piece making it out of whack. Jessebubb@yahoo.com

Maybe possible that something got bent in shipping, I can always just ship out another piece to try.


Thanks Jesse, I'm out of town for the weekend. I'll take a picture when I get back home and send it over to you.

Jpjr
08-02-09, 03:02 PM
I've installed dozens of exhausts on many cars and it almost always comes down to fitment issues since the jigs are the same. Keep workin at it...