: Keyfob battery low????



BlackedouT STS
07-31-09, 12:27 AM
How do I know when the battery in my remote is low? Over the past few days my keyless access has worked intermittently. After I change the battery in the remote do I need to reprogram it to the car? Thanks!

SKATE50
07-31-09, 12:30 AM
nope

Caroutisine
07-31-09, 12:34 AM
Keyless entry not working could be something other than the key fob battery, some have had issues with the door handle switch, etc. When my battery needed to be replaced it would give the message of "no fobs detected" when trying to start the car. You do not need to reprogram the fob when the battery is replaced.

BlackedouT STS
07-31-09, 01:36 AM
The problems didn't start until after the last time i washed my car. I tried to find the switch on gmpartsdrirect.com, but i couldn't find it. How have other people fixed this problem? Thanks!

ifmracin
07-31-09, 12:18 PM
You have to buy the inner door handle assembly.
I purchased one, but can't remember the exact part, and after purchase (not installed) it's worked fine ever since.
I'll check the one I have at home for the part number.

*edit*
Actually, i just found my web receipt.
Part number 19120306

BlackedouT STS
08-06-09, 09:27 PM
Thanks for the info! I changed the battery in my key fob and it has worked fine ever since.

DBeaSST
08-07-09, 09:03 AM
Out of curiosity, how old was the battery in your fob? I'm curious as to the typical lifespan of them.

I've been thinking of just replacing the batteries every couple years, just to be safe but hate to waste them. :)

MacMuse
08-07-09, 10:56 AM
> ...replacing the batteries every couple years, just to be safe but hate to waste them...

CR2032 batteries are $2 each. Put in Regular gas :duck: once every 6 months and blow the savings on a battery for your fob. ;)

roadog1aj
08-08-09, 04:43 PM
Hi all, I've been lurking and learning from this forum since purchasing my 06 STS4. I just love the car, but this topic is similar to a problem that just started. The front passenger door does not always unlock, no matter what I do. I end up having to manually open from the inside, then it will open. I changed the batteries in both Fobs, and reprogrammed the driver settings to only lock manually with the Fob, instead of automatically locking after exit. This helped, but the problem still happens intermittently.
I may end up taking it in to be looked at, but still wanted to see if others have had this issue.