: Cadillac BLS, Reset the Service Indicator (solution)



t4evs
07-28-09, 03:23 PM
I found this solution on a Saab forum for resetting the service indicator and it works.

1. You have to insert the key and turn it to the ignition position but without starting the engine.
2. Then push the footbrake, keeping it pushed the whole time throughout this procedure.... (cars with diesel engine only)
3. Then select "SETTINGS" on the steering wheel controls.
4. Then press and hold the "SET" button until given audible confirmation.
5. Select "TIME FOR SERVICE".
6. When asked "RESET SERVICE CHECK?" Select YES (You can undo using the CLR Button)
7. Release the brake pedal (cars with diesel engine only).

S70RMP
07-29-09, 01:46 PM
I tired this on mine in Feb and it didn't work !

t4evs
08-01-09, 06:02 AM
My car is the diesel auto version. Following the process worked first time. Good luck.

S70RMP
08-01-09, 03:16 PM
My car is the diesel auto version.

snap !

Where are you based ?

not seen that many BLS on the road.:(

PSCBLS
09-02-09, 07:23 AM
I tried this on mine too, I think perhaps this is an 'Auto' only thing.

I'll try again today whilst on lunch and report back.

S70RMP
09-02-09, 04:50 PM
Mines an Auto to

I think you have to have the service now on before you can get tot he reset.

I think !:suspense:

billynic
08-10-10, 06:56 AM
I found this solution on a Saab forum for resetting the service indicator and it works.

1. You have to insert the key and turn it to the ignition position but without starting the engine.
2. Then push the footbrake, keeping it pushed the whole time throughout this procedure.... (cars with diesel engine only)
3. Then select "SETTINGS" on the steering wheel controls.
4. Then press and hold the "SET" button until given audible confirmation.
5. Select "TIME FOR SERVICE".
6. When asked "RESET SERVICE CHECK?" Select YES (You can undo using the CLR Button)
7. Release the brake pedal (cars with diesel engine only).
hi did exactly as you said ,done in a jiffy,many thanks,,bill nic

bigcul1
08-10-10, 12:23 PM
I tried this on mine, no joy unfortunately. Mine is a manual though. Thing with mine is when you go into the SID all thats displayed is "Service:---" Im under the impression there should be a % or something shown here. What's shown in your SID and could somebody upload a pic?

S70RMP
08-10-10, 03:18 PM
it does say xx% left,tried to get a picture but it's way to blurry

bigcul1
08-11-10, 07:01 AM
Cheers S70RMP, thought that would be the case. Well I dont know what the crack is with mine but will get BM's to look at it next time im in Manchester.

billynic
07-28-11, 11:25 AM
that is correct,mines a manual bls elegance and this procedure works fine

Mazuk
12-19-13, 10:25 AM
Worked for my diesel auto too.I think service due message has to be on for reset.