: Sudden Loss of Power...rattling noise...help...04 EXT



BooSoo
07-27-09, 10:37 AM
04 EXT with 75k miles. No trouble codes. All of a sudden it completely lost power. When I accelerate hard it has barely any power and has a terrible rattling noise in the front. Any ideas??

luxurylife33
07-27-09, 10:39 AM
Your car is probably studdering from having no power, basically fighting to stay on.... its ether the battery or alternator.

BooSoo
07-27-09, 10:42 AM
I should clarify. The engine all of sudden is sluggish, with no power. It's almost as if it is running on just a couple of cylinders. Plugs are fine. The noise sounds is if pieces of metal are clanking.

fierodough
07-27-09, 11:18 AM
I should clarify. The engine all of sudden is sluggish, with no power. It's almost as if it is running on just a couple of cylinders. Plugs are fine. The noise sounds is if pieces of metal are clanking.

Is there any dark or black smoke coming out the exhaust?
Can you pinpoint where the clanking noise is coming from?

I hope its something as simple as something coming loose and pulling a wire out. But metal on metal is giving me shivers... :hide:

Give us more info.

What where you doing when this happened? Accelerating? Towing? bumpy road?

Good luck!

BooSoo
07-27-09, 11:31 AM
No smoke. The clanking noise sounds like it is in the front underside...can't tell which side. It does it on any hard acceleration.....from takeoff or at cruising speeds. The check engine flashed a couple of times but did not stay on. No codes are stored. My first thought were the cats, but not sure.

sillyboi
07-27-09, 12:40 PM
sounds scary. I hope its nothing big..

BooSoo
07-27-09, 04:13 PM
Any chance on it having to do with the PCM?

BooSoo
07-29-09, 09:39 AM
bump

Caddy3533
07-30-09, 10:34 AM
I have a question for you...... does it run fine then do this and stay that way or does it suddenly drop power like you say and the on board system says traction stability and then the power comes back. I have seen both situations happen. The dealership told me it has to do with a couple different sensors that activate the traction control which gives you a loss of power, no pedal and a ratteling noise. My '03 did this a couple times then I brought it in and they changed a couple sensors, now it is fine.

BooSoo
08-03-09, 03:07 PM
I have a question for you...... does it run fine then do this and stay that way or does it suddenly drop power like you say and the on board system says traction stability and then the power comes back. I have seen both situations happen. The dealership told me it has to do with a couple different sensors that activate the traction control which gives you a loss of power, no pedal and a ratteling noise. My '03 did this a couple times then I brought it in and they changed a couple sensors, now it is fine.

It does it constantly. It seems fine until you actually give it some gas, then you notice how sluggish...it barely goes, then the awful rattling noise from the front end. I didn't notice the trac stability light though. The check engine will flash a few times but won't stay on or store a code. Thank you for the reply.

trapshooter40
08-02-10, 01:23 PM
I am having a similar problem on my 05 ESV but it seems to only happen when the air is on. The sound that it makes is like a loud growling.. I do not get any messages or check engine lights. I am going to change out the exhaust from the cat back next week, but I dont think that is going to solve the problem.

ngphotboy2
10-29-11, 03:06 PM
Do u know what sesor they changes because i'm having the same problem with my 02 escalade ext. I'm burning alot of gas and it seems like the cat converter is stopped up. I can tell by the way the air intake sucks in air.

dandel
10-30-11, 10:31 PM
is one of the front bearing wheel sensor it happent to me twice

blackescalade79
11-25-12, 09:04 PM
Same problem here.. 04 ext.. engine light came, stayed and only worked out why it appeared when I hit the gas.. Will rev high, but no go.. somethin rattlin.. so they must be Tried to remove cats, but the 3nuts at the top of the pipe have pretty much welded themselves on.. Breaker bar, rattler, blow torch, lubricant sprays eventuated in the nut rounding itself..

Mechanic down here in Aussie land recommends sensors after cat be permanently shut off... That would do the trick if the cats were removed and straight pipe installed considering we don't get checked down here for emissions..

the cadillac man
11-25-12, 10:15 PM
Same problem here.. 04 ext.. engine light came, stayed and only worked out why it appeared when I hit the gas.. Will rev high, but no go.. somethin rattlin.. so they must be Tried to remove cats, but the 3nuts at the top of the pipe have pretty much welded themselves on.. Breaker bar, rattler, blow torch, lubricant sprays eventuated in the nut rounding itself..

Mechanic down here in Aussie land recommends sensors after cat be permanently shut off... That would do the trick if the cats were removed and straight pipe installed considering we don't get checked down here for emissions..

sometimes a rattling noise can be caused by the heat shield of the muffler

blackescalade79
11-29-12, 07:19 PM
Unfortunately it wasn't that.. And it's impossible for a heat shield to set of the engine light...

Exhaust guy says to permanently disconnect the after cat 02sensors... anybody done this? Or even removed cats and run straight pipe? Out of options here..

the cadillac man
11-29-12, 07:27 PM
I should clarify. The engine all of sudden is sluggish, with no power. It's almost as if it is running on just a couple of cylinders. Plugs are fine. The noise sounds is if pieces of metal are clanking.

Are you getting the reduced engine power message?
If yes then it will cause the clanking noise and no power
If no then it may be the fuel pump failing(I had this happen to me not fun on the highway)

jrock2324
12-05-12, 03:54 PM
i just had the same problem on my 04 ext too miss firing and rattle in the front. i had to replace my cat and the upper and lower 02 on the driver side. now everything is fine

like_a_rock
12-05-12, 09:31 PM
my guess is one of the catalytic converters internals are loose (ie rattling) and being that they are a honeycomb design when they break down enough the 'honeycomb' turns and blocks the exhaust. have the back pressure tested at one of the oxygen sensor hole upstream of the converters. good luck

bruno9305
05-23-13, 11:14 PM
my 06 cts is rattling at acceleration too and it feels like im losing power but as soon as the car gets up the noise goes away. I had the catalytic converter checked and no problems. can someone help me?