View Full Version : Change Engine Oil Reset not working

07-15-09, 04:04 PM
I have just changed my oil on my 2002 Escalade. The process of pressing and releasing the gas pedal 3 times within 5 seconds, while the key is set at the on position is not resetting my Change Engine Oil Light. Does anyone know of any other solutions, or reset options???

07-15-09, 04:10 PM
If I remember correctly, its 5 times, not 3

07-15-09, 04:19 PM
According to the owner's manual it is 3 times within 5 seconds...but I will try it.


07-15-09, 05:12 PM
Yea i have an 02 and its five times. Actually just did it a few days ago.

07-15-09, 05:20 PM
Hmmm...I just tried both 3 times and 5 times within 5 seconds and still no dice. Any other suggestions???

07-15-09, 06:05 PM
i remember that i didn't wait five seconds. i just turn to the on position and i waited for the chiming to stop, then i did it. five full pushes of the gas pedal then the oil light will flash five times. it will then flash five times again when you turn on the motor. If that doesn't work you might want to get that checked out.

07-15-09, 11:23 PM
I had a 01 Yukon Denali & now a 06 Escalade. All I did was turn the ing on, not to acc, but on & pushed the gas down 5 times really fast. I never counted the time in-between, just the number of pushes & it worked for me.