: Anyone else have the K&N "whistle"?



GTS21
07-20-04, 10:25 PM
I'm hearing a slight whistle at certain RPMs with my More Perf. CAI. I understand that a whistle with a K&N is pretty common. Anyone else hearing this?

D148L0
07-20-04, 10:55 PM
Nope. I have installed K&N in almost all my cars, never heard something like that.

jspinetto
07-20-04, 11:54 PM
I hear it too.

Anyone else ?

Jonathan

ssmith100
07-21-04, 12:12 AM
Check all your fittings. On all my cars that whistled I found either a loose fitting or clamp.

SHane

jdodman
07-21-04, 05:56 AM
Mine whistles all the time on my Buick Grand National. Or wait a moment, maybe that is the TE63 Turbo that likes to whistle so much.... :)

KJTROT
07-21-04, 07:33 PM
I have had the MORE CAI kit since April with no whistle. I just have the singing sound of oooooohhh at about 2000 / 2200 rpm as reported by others on this board. Just check the fittings as previously stated.
LOL :hmm:

rotdog
07-22-04, 02:53 AM
I installed the moreperformance & also can hear that whistle. I fixed by slightly adjusting the Volume on the Radio to the right.

D148L0
07-22-04, 10:59 AM
haha!! :devillaug

GTS21
07-22-04, 12:35 PM
I spoke with More Performance, and they indicated that it's normal. I also searched around and found out that a lot of other makes and models with the K&N have the same "issue". I guess I'll just live with it. Maybe the Corsa (when the heck is it coming out!) will mask it. Strange though, I have K&Ns on my 02 Viper RT/10, and no whistle. :confused:

Vedder
07-22-04, 02:48 PM
If this is normal how did some of you guys get rid of it? :hmm:

BeagleBrains
07-24-04, 12:08 PM
Corvette, Pontiac TransAm, Jeep Wrangler 6Cyl. K&N on any of these, I hear the whistle usually at initial start when accelerating slowly. Works fine.