: 93 seville driving on its own



pimpjuice01
07-20-04, 01:15 PM
My car out of no where will give itself gas out of nowhere, and also the idles sometimes changes going up and down. When I'm driving sometimes, I don't even have to let go of the gas because it'll drive for me keeping the same rpm.

Also get code p070 history,

Not sure where tps is, if thats the problem

pimpjuice01
07-21-04, 03:56 PM
Anybody, :bouncy:

caddyshack24
07-21-04, 04:16 PM
Instead of answering direct, check this story out. (I have the 1993 STS)

My ISC motor was acting up and I had a leak on the hoses, the ones on top of the throttle body. So sometime when i'd start the car, it would idle at 1-4k RPM.
Would accelrate itself to about 60, transmission didnt want to downshift, was getting 8 mpg on average (but this thing could move!!) .. anyways, I replaced that peice for $120 and havnt had a problem since. Well, the ISC motor acts up on occasion.. usally wants to stall out with the A/C on when you come to a stop.. but doesnt, and when it does.. you can bang on it .. works fine.

TPS is mounted on the side of the throttle body, torward the front of the car.
Either you have a faulty TP Sensor, Wires chaffed or binding on the throttle or sticking throttle cable.. (TP Sensor is maybe $60)

pimpjuice01
08-06-04, 11:46 PM
I replaced the tps, and still my car will drive on it own. I'll drive down the road, let go of the gas and it won't want to idle down for a while or I have to keep tapping the gas. Also the voltage when I do a scan on idle, I'm getting 2.6 volts or so, I heard it should be at 1. I tried to do the idle reset, but still have the same problem... ANy help

Aurora By Olds
08-07-04, 01:42 AM
Check your ISC motor.
When my headgaskets were leaking, it would blow coolant out of the surge tank cap, and it would drain down and short out the harness at the ISC motor connection. Mine would idle high, "drive on its own," and constantly stall as well.
I got the same TPS code, tried the idle relearn, and nothing worked until I cleaned the harness going into the ISC motor. Yours may be dirty, or the ISC may be shot. Check it out and see...

pimpjuice01
08-08-04, 07:34 PM
Where is the ISC motor

Twilightcall
08-09-04, 06:57 AM
Can someone post the link to the relearn for the TPS. I searched and searched. The only thing I found was to turn the key on but not start the car three seperate times. Is that the relearn?

I think the ISC is located right next to the throttle body.

caddyshack24
08-09-04, 03:38 PM
yeah, it has a little plunger the pushs on the throttle.. its behind and below it. under the accelorator cable and in front of the cruise control servo.

Here's the procedure
http://cadillacforums.com/forums/showpost.php?p=120185&postcount=5

pimpjuice01
08-13-04, 12:30 PM
I'm also getting no codes, just S055 and S044 history.

Also just about rear ended someone because the car was accelerating on its own while I had the brake on full

Eldyfig
08-13-04, 02:41 PM
Thats the long way, i think you can disconnect the negative battery for 30 seconds also..

That is the long way. My Eldorado manual has a much shorter version, but probably still takes the same amount of time. I'm fairly sure, anytime the battery is disconnected and the pcm loses power, an idle learn procedure should be done.

Pimpjuice:

S044...Lift or Dive Signal Fault

I don't worry about that one too much. Ever since I did my trans work, that one comes back occassionally. I think the sensor plug is not firmly in place.

S055...Resistor Module Short to Ground/Open

I don't think these codes are causing the problems you mention. These are suspension codes.

Eldyfig
08-13-04, 02:53 PM
My ISC motor was acting up and I had a leak on the hoses, the ones on top of the throttle body... ... anyways, I replaced that peice for $120 and havnt had a problem since.

Did you replaced the black plastic part on top the throttle body that the hoses attach to? I think there are three ports on it. I noticed, the other day, one of my hose ports is cracked longways. I have a wire tie around the end of the hoses trying to keep vacuum from leaking. If that is what you replaced, what is it called and where did you get it? Thanks for the info.

pimpjuice01
08-13-04, 08:00 PM
I replaced the ISC motor, 150$ cdn. The idle is kicking down a lot better now, but now I'm getting 3 other codes.

PO61 current
PO62 current
PO65 current.

Also those suspension codes, my suspension is acting like crap. NOt sure if I need to replace them completely or the electronics are messed.

sts rider
02-23-09, 04:28 AM
my sts does the same thing please help I have p065 code current can I bypass cruise control I allmost died my 93 sts was doing 45 by its self and would bearley let me press the break I had to shut the car off at 15 mph hour?????!!!!!!!!!!