: Hot Air Coming out of right vents not left



1BigEng
07-06-09, 09:15 PM
Put new battery in my 2005 Escalade after that with the AC on set on 60 degrees hot air coming out of vents on both sides, now cold air coming out of left side not right, compressor is running. What do I check?:confused:

ToddLewis
07-08-09, 06:21 PM
Yea this is happening to mine as well. Ive been told two methods to fix it but neithr have worked so Its off to the dealer for me on friday.
1st they say disconnect the battery for awhile and put it back on (this may take several trys from what ive heard)

2nd would be the easiest that use to work for mine (but the problem allways came back after a few days) Pull over turn the vehicle off and open both front doors and start it back up.

Like I said though the one worked for me temporarly and the other after about 15 trys I gave up and made an appointment for friday.

If you come up with something more (befor friday) please let know

nathanjax
07-16-09, 01:53 PM
Any updates? Mine's starting to do it as well.

Thanks,

Nathan

easter9053
07-17-09, 12:36 AM
Mine was blowing out ambient air. Left actuator was not working and replaced. Now air blows mostly cold, but still not COLLDD!!

93civEJ1
07-20-09, 11:01 AM
mine did this randomly one day. I powered off the thing, went into the store...came outside and it was fine then.

skills2005
07-22-09, 10:21 AM
I was having this problem this morning with my 05 EXT. After reading for about an hour I attempted to see if I could fix it. I started the truck and no hot air, it was all cold again. Anyone had this problem and it is going to keep going from hot to cold at random

rwonder
10-12-09, 11:25 AM
I had the same problem last week. My battery needed to be replaced. After replacing the battery the ac was blowing one side hot one side cold. I turned the ac off, disconnected the battery and waited for like an hour and reconnected. Turned the ac on and it is working. It has been 5 days will post if it does it again.

nathanjax
10-12-09, 11:32 AM
I had the same problem last week. My battery needed to be replaced. After replacing the battery the ac was blowing one side hot one side cold. I turned the ac off, disconnected the battery and waited for like an hour and reconnected. Turned the ac on and it is working. It has been 5 days will post if it does it again.

That's a temporary fix... Since mine was doing it, I did a lot of research, and it's the blend door actuator. I posted more info here...

http://www.cadillacforums.com/forums/cadillac-escalade-ext-esv-forum-1999/180687-04-esv-c-problem-newbie.html