: 1976 DeVille Climate Control Issues....



DopeStar 156
07-06-09, 10:06 PM
The Climate Control in my '76 DeVille isn't working correctly and I was wondering if anyone could point me in a direction to try and fix it. This is what it does when I move the slide lever to each setting.

Off: Blower on low from floor (normal cabin venting proceedure)
Econ: Nothing
Def: Works normally
Low: Blower on low
Auto: Nothing
High: Nothing

The only thing I can come up with is the blower motor is shot and only works on a low setting, I dunno. Any thoughts?

77CDV
07-07-09, 12:18 AM
Sounds like a bad programmer.

DopeStar 156
07-07-09, 01:58 AM
Programmer aye? Where can I find this component? Is it something I can get or is it a special Cadillac only part?

greencadillacmatt
07-07-09, 02:01 AM
Might it be the resistor block for the settings? If that's shot then some of the settings might work, but others may not. Just my two cents.

DopeStar 156
07-07-09, 02:14 AM
What about the Auto Relay? My FSM seems to mention it for "Fan Operates Only on Low."

cadillac_al
07-07-09, 07:16 AM
I think the blower relay has failed. I have no idea if you can buy new ones.

77CDV
07-07-09, 09:27 PM
Both the blower relay and the programmer are available. The blower relay is cheap, the programmer, not so much. Check for tight connections at the control head, and for opens in the blower circuit wiring (you'll need the wiring diagram in the FSM to do this). Usually when the blower relay goes out, the blower won't work at all (except in DEF). The programmer is what steps the blower speed up and down in AUTO and controls the air distribution doors based on feedback from the in-car temperature sensor.