: Random light miss during constant hwy cruising



stngh8r
06-30-09, 01:16 AM
I have a very random and intermittent miss noticed during consistent highway speed. The miss is very light, but noticeable. e.g. on an hour long trip, it may only occur 2-5 times.

maintanence in the last year or so (which hasn't effected the symptom being discussed).

-New plugs
-New wires
-Used lower mileage coil pack/module
-New FPR
-New fuel filter
-Cleaned EGR
-Random fuel treatment (~3x)
-Sea foam in spark plug holes, let sit for few hours.
-Cleaned TB as good as possible without removing it.
-Cleaned MAF


? Possible culprits ?
-Fuel pump
-injector
-vacuum leak (although it idles fine and shows no sign of this)


Please help!

Thanks for your time

Krashed989
06-30-09, 01:41 AM
Any codes?

stngh8r
07-03-09, 07:33 PM
No codes.


BUT........

-Just a few hours after writing the O.P. I remembered! I had basically the exact same symptoms with my Vette.

With the Vette, the injectors were maxed out anyways, so they were certainly due for a change whether it be because I had "out grown them" or they were flat worn out.

Needless to say, I did not realize how worn out they were, because new injectors took care of my random misses in the Vette.

My guess is, I have answered my own question. The culprit is worn out injectors.

Thanks

Eric

Krashed989
07-03-09, 07:39 PM
I hope you're right. Fuel injectors are pretty expensive.

Did you replace the spark plug wires with OEM AC-Delco wires?.... Cadillacs seem to be really picky about that. A lot of generic brands will cause a small miss, or they simply wont last very long.