: Lockpick Trouble



EChas3
06-14-09, 10:50 PM
I'm having trouble with an unmodified Lockpick in a 2007 STS. The Lockpick is only supposed to engage after pressing the steering-wheel mute button four times.

When starting the car, the Lockpick seems to already be blocking the VSS (Vehicle Speed Sensor) so the Nav System does not accurately detect the movement of the car. It sometimes gets 'lost' and shows a current position that is 'out in left field'. Pressing the Mute four times seems to turn off the Lockpick and after a while, the Nav will figure itself out.

The same thing may happen when going through multiple Nav functions quickly. At first I thought I had poor GPS signal, but now I think the Lockpick is engaging unexpectedly. I got into the dash today to make sure all the connectons were good. I also made sure the GPS antenna wire was solidly connected. The behavior hasn't changed.

It's my wife's car, so I don't drive it all the time. We will be taking a driving vacation in a week, so I'm sure to get a lot of trouble-shooting info by July. Anyone have similar trouble?

All suggestions are appreciated.

trackbait
06-15-09, 02:15 PM
Ineresting.. I had the exact same problem on my 08 unmodified. Nav never could figure out where it was and the DVD / BT/ all intermittent.. Never really worked.

Tried a different lockpick module - no luck there either. Kept the lockpick module and getting a 'modified' harness to see if that works.

Good luck with yours. Let me know what fix you find on yours.. I'll post back when I get new modified harness (with switch) and see if that fixes it.

EChas3
06-15-09, 05:23 PM
I've had it installed over a year and only gotten complaints recently. I may get the Nav upgraded and then see if it persists.

I actually prefer my modified one (with the button). Thanks Tomm.

tomm
06-18-09, 09:07 PM
Here are some findings that we came to realize when doing testing last year when we started the process. The STS does not have switched power going to the navigation unit. The Navigation unit always has power and relies from a command from the GM Lan to turn on when you hit the accessory power button or start the vehice.

Because the lockpick taps the power from the navigation connectors the lockpick always has power. If we had activated the lockpick in the 2007+ vehicle many times when we left the vehicle and then re-entered it the lockpick was still activated because it was never deactivated before we turned the vehicle off. (This is what you might be experiencing)

Also, The navigation system even prior to installing the lockpick always had satellite signal issues (Many times in normal driving I would see the line through the GPS indicator) but since the navigation system relied so heavily on VSS even with no signal I always seemed to be on the map properly.

This issue comes into play when you are using the lockpick and the GPS signal is interrupted. From the time you activate the lockpick you will not move on the map which is normal. But if lets say you end up parked in a location that does not have a good signal when you start the vehicle even if you deactivate the lockpick the navigation system might still have you in the wrong location until it see a strong enough signal (Needs to pick up 3 satellites at the same time) to recalibrate you correctly on the map. I have seen this take anywhere from a few seconds to as long as 5 minutes to recalibrate you.

EChas3
06-18-09, 09:52 PM
Thanks, I appreciate the insight. We are going on a driving vacation & I will validate the performance in the light of your findings. One factor seems clear. The Lockpick is probably best kept off and used minimally for NAV to work its best.