: Bluetooth call answer doesnt mute radio?



K STS
06-13-09, 03:47 PM
Anyone else have this problem? Ill get a bluetooth call, and when I click the green answer button to accept, it connects the call and doesnt mute the radio, or allow me to turn the volume down on the radio!

Force-1
06-13-09, 06:05 PM
In my car the NAV software update corrected that issue.

EChas3
06-13-09, 08:43 PM
This is usually due to the STS Bluetooth not getting the mute instruction from the phone. It can be a metter of timing. Have you tried answering the phone by pressing the VR button on the steering wheel? I find it easier and it may change the timing of communications between the car & phone.

The Nav firmware upgrade is well worth doing. I'm convinced the Bluetooth, VR & Nav system work better.

dhemrick
06-14-09, 10:17 AM
This is usually due to the STS Bluetooth not getting the mute instruction from the phone. It can be a metter of timing. Have you tried answering the phone by pressing the VR button on the steering wheel? I find it easier and it may change the timing of communications between the car & phone.

The Nav firmware upgrade is well worth doing. I'm convinced the Bluetooth, VR & Nav system work better.

You know, I had begun to suspect that it is a timing thing as well. One thing I have noticed is that instead of simply tapping the green "answer" button when receiving a call, if I press and hold it for a couple of seconds I seem to avoid the "failure to mute" issue almost every time.

I'm not sure if this is really true as I have not done any formal experiments, but it seems to work for me.

K STS
06-14-09, 11:33 AM
thanks. ill try this. and ill get the nav update

Force-1
06-14-09, 12:33 PM
thanks. ill try this. and ill get the nav update

Also make sure your cell phone has the latest firmware/software updates.

Dirny
06-17-09, 10:28 AM
I have the NAV upgrade, using an iPhone with 2.2.1 software, and I still have the problem, but only occasionally. That occasion is usually when i get an important call while listening to the radio at a loud volume. How frustrating!!

Also, I cannot recreate the problem while sitting in my driveway and utilizing two phones. It will mute everytime. So I tried programming a destination and sitting in my driveway, thinking I will be taxing the computing system more. It still would mute every time.

Giving up, I head out the next morning, and it fails to mute the first call!! Using steering wheel button vs. touch screen doesn't seem to matter to me.

I will try to "hold" the green button next time and see if that has any affect.

Anyone else have a suggestion?

This drives me crazy.

K STS
06-18-09, 10:03 AM
Yeah, using the voice command button on the steering wheel, and "holding" the green button does nothing for me either. Its always when I have an important call and my music up as well! Ill be taking it in for the nav upgrade in a month or so.

bruce giammattei
06-23-09, 11:43 PM
I find that waiting for the phone to ring twice allows the phone and car to be fully engaged. When I have this problem I've noticed that I answer the phone as soon as I heard it ring.