: Does Anyone Have Any Ideas???



UNKUT
06-06-09, 01:42 AM
My 2000 DTS started doing this periodically..... and now its got to the point its doing it every other time I go somewhere. Sometimes it makes the car shift hard like it doesn't know what speed its going!



YouTube - 2000 DTS

UNKUT
06-06-09, 02:03 AM
Here's the latest 2 codes I'm getting.....

RSS -- Road Sensing Suspension

P0503 - Vehicle Speed Sensor (VSS) Circuit Intermittent

P1575 - Extended Travel Brake Switch Circuit

STSS
06-06-09, 10:21 AM
You need a new Vehicle Speed Sensor... do some searching

Submariner409
06-06-09, 10:59 AM
VSS is on top of the right (passenger) axle output casting.

UNKUT
06-06-09, 11:38 AM
You need a new Vehicle Speed Sensor... do some searching

When I try to look it up it shows 3 different sensors. How would I know which one to replace?

jeffrsmith
06-06-09, 12:11 PM
One question for anyone:

He says he is getting codes for VSS - should that be causing all the other warning lamps in the lower right of his display to be lit?

Submariner409
06-06-09, 02:06 PM
UNKUT, In Rock Auto, under your car, electrical, there is only one VSS shown, $15.

.................and jeffrsmith is correct: you have some other serious problems. Serious.

00 Deville
06-06-09, 06:32 PM
.................and jeffrsmith is correct: you have some other serious problems. Serious.

He's got quite a bit going on with his DTS.... he has a thread going on in the Deville section addressing his other issues.

UNKUT
06-06-09, 09:28 PM
Yeah everyone my DTS is really having some troubles right now. It all started with the speedometer bouncing around like in the video I posted. Then days later I got the Service Engine Soon light. A few weeks later during a down pour my ABS, Traction Control, and Brake lights lit up. They are hit and miss.... but mostly they stay on. Below are a list of codes I pulled recently and they DO return after clearing them. Also now the car is shifting hard and the speedo problem is out of control, not hit and miss anymore.




Powertrain Control Module

P0443 - EVAP Purge Solenoid Valve 1 Control Circuit


Antilock Brake System

C1214 - System Relay Contact or Coil Circuit Open
C1248 - EBCM Turned the Red Brake Warning Indicator On


Instrument Panel Integration Module

B0429 - Temperature Control #3 Rear Circuit Range/Performance



Here are the latest two additions to my code grief!!!


RSS -- Road Sensing Suspension

P0503 - Vehicle Speed Sensor (VSS) Circuit Intermittent

P1575 - Extended Travel Brake Switch Circuit

Destroyer
06-06-09, 11:00 PM
You need a new Vehicle Yeah that!:highfive:

UNKUT
06-07-09, 12:34 AM
Yeah that!:highfive:

Actually my GM Protection Plan (Major Guard) just expired, so everything has been WELL maintained. I used the warranty with its measly $50 deductible every time something didn't feel/sound right, haha! I really miss it...... That and the basics like oil (synthetic), filters, ect. have all been changed on or before there scheduled date. And did I mention the body/interior is in MINT condition.... with only 65K miles??? ;)

There has to be something causing all of these malfunctions to occur around the same time. That or I have extremely bad luck! I'm going Monday to have my battery/starter both re-tested at another location just to be sure thats not the culprit. Once I emliminate both of those as suspects I'll start throwing money/parts at it. I had my second window regulator fail recently and that will be installed Monday as well. I'm expiditing a vehicle speed sensor to install Monday as well. Problem is without a manual I need to find its exact location and and tips/tricks would be greatly appreciated. Or if anyone knows of a online picture of the sensor installed..... that would be INCREDIBLE!!! But to further respond to your comment.... HELL NO.... my Lac just hit puberty, hahaha! We've got many years/miles to go!!!

Submariner409
06-07-09, 10:41 AM
VSS diagram.....as posted.

UNKUT
06-07-09, 01:12 PM
VSS diagram.....as posted.

NICE!!! Thankyou!!!

tateos
06-08-09, 04:34 PM
As I recall, in the car, you pretty much have to put your hand up there and find it by feel. I had one that start acting up once, removed it - ohms checked out, replaced it, and no trouble since - been many years - maybe was a bad connection in my case?

UNKUT
06-08-09, 07:44 PM
VSS is on top of the right (passenger) axle output casting.

Do I remove the wheel? I can't seem to find it laying under the car.... or from the top? I purchased the new one just need to locate and swap em! PLEASE..... can anyone guide me....

Submariner409
06-08-09, 08:16 PM
You can pull the wheel/tire and inner fenderwell inner and go in from the side or put the car up on a 4-point lift at the hobby shop and do it by Braille.

What about your local Junior College VoTech shop ???

UNKUT
06-08-09, 09:24 PM
You can pull the wheel/tire and inner fenderwell inner and go in from the side or put the car up on a 4-point lift at the hobby shop and do it by Braille.

What about your local Junior College VoTech shop ???

Well I ended up jacking up the passenger side front. I then slid in behind the wheel and when I reach up to locate the VSS there was a metal plate blocking the top of the axle case, so I removed the 3 bolts holding the plate and bam.... there it was held in with a single bolt! I replaced the sensor, vleaned the wiring with electrical cleaner, and put it all back together. Took it for a test drive and damn she's smooth now! No rough shifting, No erratic speedo, and No more P0503 codes!!!

UNKUT
06-08-09, 09:27 PM
So now onto step 2 of the process. I need to eliminate the following code:

Powertrain Control Module

P0443 - EVAP Purge Solenoid Valve 1 Control Circuit

Its throwing the SES light so if anyone knows what part I need to fix this it would be appreciated. I was gonna switch out the EGR valve, but wasn't sure it would fix the problem. Any ideas???

STSS
06-08-09, 09:53 PM
From the looks of the FSM for my 01 STS... looks like you need an Evap purge valve.... its part of the fuel/emission system. I couldnt find the part no quick on rockauto.... look around here (http://gallery.iametarq.com/cars/cadillac%201998%20seville%20sls/parts%20list/1998-2004SevillePartsList.pdf) or call a dealer to get the part no.

UNKUT
06-09-09, 12:29 AM
From the looks of the FSM for my 01 STS... looks like you need an Evap purge valve.... its part of the fuel/emission system. I couldnt find the part no quick on rockauto.... look around here (http://gallery.iametarq.com/cars/cadillac%201998%20seville%20sls/parts%20list/1998-2004SevillePartsList.pdf) or call a dealer to get the part no.

Yeah I can't locate that part by name ANYWHERE! I even called Autozone & Advance Auto, neither of which had or knew what I was refering too, ha! Why does everything gotta be so hard....:bomb:

UNKUT
06-09-09, 12:45 AM
Oh, and while I was at it I took a peak at the throttle body, and it was super clean! I tried to check the IAC valve as well, but the 2 screws that hold it in place were siezed..... and no matter what I tried they wouldn't budge!!! I'll be searching for more info for hours to come.......