: 06 AWD Making rubbing noise in front pass side



Buyouts
06-04-09, 09:12 AM
My 06 AWD with 51k miles just started making a rubbing noise in front pass. side. Sounds like bushing is dry or something. Anyone have any ideas?

Professor Wizard
06-04-09, 02:20 PM
Several ideas.

Right front - - Wheel Bearings would be the first thing to check... next the brake calipers rubbing (slides rusted so calipers can't open). then Axel Bearings.

To test.. jack up front of car. Grab tire and first gently move side to side and tilt top/bottom back and forth.. feal for tightness. If there is play, or clunking then good likelihood of bearings. Pull/push on tire laterally, if you feel in/out movement, could be axel bearings. Turn wheel by hand.. listen for grinding noises, and for rolling rocks noise. also for "depth" of noise.. if you do get noise and it sounds close to the outside.. it is wheel bearings.. if noise sounds deep inside.. it is axel bearings...

Breaks will just make dragging noise with a slight ringing along with noise when you rotate the tire.

Good luck with that!

Vettenut48
06-11-09, 12:02 PM
Had the same issue a month ago, my issue was the brake dust shield, dealer adjusted, no more noise.

King3244
06-14-09, 10:45 AM
I had the left front upper control arm replaced (warranty) on my 07 to fix the problem. Made that scrunching noise going over speed bumps or when turning into a driveway from the street.

Buyouts
06-16-09, 09:29 AM
It was the front shock. They said the shock mount was bad and they come attached to the shock. Now I need to know where to get good shocks and if I should replace them all.

King3244
06-17-09, 12:09 AM
www.rockauto.com

Buyouts
08-17-09, 02:06 PM
Still having problems with this. It wasn't the shock. I can bounce the car up and down on passenger side and it just squeaks sounds like a bushing. I looked for bushing kits and they don't make them for this car they say I have to buy the whole control arm but not sure which one it is. Has anyone had this problem. only has 53k miles on it and of course out of warrentee.

mthake
08-17-09, 09:28 PM
I just wasted over $300 on a new upper control arm, dealer replaced it and it did NOT fix the issue:want: now a new shock is on order, as they believe that is the issue. Should have it replaced sometime this week and will let you know the outcome:alchi: