: 01 STS Water pump grumbling noise



joe45
05-19-09, 09:09 AM
My water pump on my 01 sts has been making a grumbling noise for the last 5000 miles or so. Since we have a long weekend coming up I wanted to get it fixed. I did remove the belt and started the engine and the noise stopped. I then inspected the tensioner pulley and lubed it but that part seems fine. I have never changed out the water pump on a northstar before so I donít if a cartridge swap will make the noise go away or if there is a bearing some where separate? Its not leaking any coolant just making a noise.

Submariner409
05-19-09, 09:20 AM
If you still have the cover, belt tensioner, and belt off the water pump, reach down in there and spin the pump pulley by hand. Any noise or roughness and it's pump time. You're correct: the thing is a unit capsule. You need a special socket to remove the pump - you turn the pump clockwise (right) to remove it and counterclockwise to lock it back in. BE SURE you take a good look at the locking tang locations so you start the new pump correctly. You will need either the GM pump socket or a substitute from NAPA or a large auto parts store, and if the socket does not have the bolt-on retainer strap supplied, a friend needs to supply a healthy push on the head of the socket wrench to keep the socket engaged with the pump. There have been several pictures of the sockets required and procedures posted here and in Northstar Performance over the years. Get the pump from www.rockauto.com or Luke in parts at Lindsay Cadillac over there --------->

(You may get away with lubing the tensioner pulley, but I would replace that, too................)

joe45
05-19-09, 09:35 AM
I am familiar with the special socket and how it can be a real treat to get off from reading some of the posts here. I did not spin the pulley with the belt off because the engine was still hot I just wanted to rule out the tenisoner. Is there a bearing on the water pump itself or does the replacement cartridge kit have everything I with need?

Submariner409
05-19-09, 09:39 AM
The whole thing is a sealed capsule unit - pull the old one, stick the new one in. Make sure you get a new pump O-ring seal.

Take a look at the pictures for your car, cooling system, in RockAuto - click on the (!) icon for a larger view.

kckranz
05-19-09, 09:45 AM
Yup - Go ahead and replace the tensioner pulley and belt while you're in there. I got the socket from eBay for $26 delivered and my local NAPA store matched Rock Auto prices (all Delco parts except for the belt). Others describe the R/R process as easy but I found using the tool quite clumsy. Start to finish it took me 2 1/2 hours and several magic words (as Sub calls them). There has got to be a "special" tool to remove and reinstall all those hose clamps - at least use stubby pliers - I dropped f-bombs left and right trying to maneuver 12" adjustable pliers :(

joe45
05-19-09, 09:55 AM
So I don't need any gaskets just the o-ring?

kckranz
05-19-09, 10:09 AM
Correct - The Delco pump will come with the new o-ring.

tateos
05-19-09, 12:55 PM
Well - there is a gasket/o-ring on the cover, but it is re-usable if it is not leaking

00 Deville
05-19-09, 10:37 PM
There are 2 o-rings one that comes with the pump. The other is for the cover. The cover has been redesigned the old design was prone to leak. While you are in there I would also replace the old cover with the redesigned cover p/n 12600022, redesigned cover gasket p/n 12600020 and redesigned thermostat gasket p/n 12574478.

joe45
06-15-09, 11:19 AM
I replaced the water pump this last weekend and I highly recommend an impact wrench for removal of the old one. I can not believe it wasnít leaking for how shot the bearing was. I will note I put 10K on the water pump while it was making the noise. I guess I was just lucky.

tateos
06-15-09, 01:55 PM
Thank you for the update - yeah, an impact wrench or a long breaker bar will do the trick