: Engine almost stalls



Dadillac
05-13-09, 10:23 PM
So my '02 SLS has developed an issue. At completely random times the engine will drop RPM to the point of almost stalling, and then return to normal. It will occur when the engine is cold, warm, or hot. It will occur when the car is in motion, or when standing still. It never sets a code so I am at a loss. My only guess would be possibly the battery. The battery is the original so it is at least 7 years old. The dash is showing the volts right at 14.4 so it is reading okay. I will say that the dash used to read 14.9 to 15.0 always. Is my battery biting the big one?

Don

Ranger
05-13-09, 10:30 PM
I think your battery is fine with those voltage readings. Are the CKP sensors original?

Dadillac
05-13-09, 11:10 PM
The CKP were changed out several years ago. When I was having CKP issues, it would stall very now and again. The almost stall issue I am having is happening everytime I drive the car. Thus why I was thinking a battery issue.

Don

Submariner409
05-14-09, 07:49 AM
Even if the battery was toast, the charging system is apparently providing enough voltage/amperage (14.4) to efficiently run the car.

Your problem sounds like idle speed control, dirty throttlebody, vacuum leak, or some such engine-related bug.

Codes ???

Ranger
05-14-09, 10:30 AM
Even if the battery was toast, the charging system is apparently providing enough voltage/amperage (14.4) to efficiently run the car.

Your problem sounds like idle speed control, dirty throttlebody, vacuum leak, or some such engine-related bug.

Codes ???
That would have been my next guess. Don't overlook the ever popular ripped plenum.

Dadillac
05-14-09, 10:22 PM
Even if the battery was toast, the charging system is apparently providing enough voltage/amperage (14.4) to efficiently run the car.

Your problem sounds like idle speed control, dirty throttlebody, vacuum leak, or some such engine-related bug.

Codes ???

I know very little about the sensors and what not so bear with me. If the ISC were failing, wouldn't I be getting codes? A vacuum leak should be a more steady issue, and should become more pronounced while under load. Correct? I am getting no codes when this issue arises.

Don

Dadillac
05-14-09, 10:23 PM
That would have been my next guess. Don't overlook the ever popular ripped plenum.

If the plenum is ripped wouldn't that act more like a vacuum leak? And wouldn't it actually cause the RPM's to rise?

Don

Ranger
05-14-09, 10:40 PM
It would seem that way, but I have seen many of them act very weird here. It's easy enough to test. Just spray some Brakeleen near the base of it. That is where they generally rip. Listen for an RPM increase.

Dadillac
05-15-09, 10:42 PM
It would seem that way, but I have seen many of them act very weird here. It's easy enough to test. Just spray some Brakeleen near the base of it. That is where they generally rip. Listen for an RPM increase.

I'll try that tomorrow while I do mt brake job. Thanks

Don

Dadillac
05-16-09, 07:46 PM
Well I sprayed the plenum with brake clean and there was no idle change. So I guess I can rule that out.

Don

Ranger
05-16-09, 07:55 PM
When was the Tb last cleaned?

Dadillac
05-17-09, 12:59 PM
When was the Tb last cleaned?

That was about two years ago. I was actually thinking of doing a cleaning this afternoon. My almost stalling issue hasn't happened in a few days so I will wait for it to return to look further. But I guess it wouldn't hurt to clean out the throttle body.

Don

Ranger
05-17-09, 02:30 PM
I do mine every spring Don. Probably a little more often than needed, but it makes the job a piece of cake.

C0RSA1R
05-17-09, 06:39 PM
I cleaned my TB and had a very noticeable performance increase. Thanks to the step-by-step instructions on this forum, it only took about 45 minutes from start to finish (including finding a proper CD to listen to while I was working).

Dadillac
05-19-09, 05:51 PM
I cleaned the throttle body and it wasn't too gunked up. It only took about 10 minutes. I drove the car yesterday and the almost stall occurred one time. So I am at a loss. i just wish it would throw a code. At least I would know where to look. Thanks for the tips guys. I am just gonna drive it and if it ever actually stalls hopefully a code will set that will help me.

Don