: How to rebuild the power antenna



N*Caddy
05-09-09, 06:55 PM
In the last week I had problems with my power antenna (or power mast). At some point refused to retract.
Please be aware; if your power antenna is stuck immediately disconnect the power harness from the relay mounted on the antenna. Remove the liner to access the antenna and disconnect ANY of the two connectors attached to the relay. If your antenna does not locks to the end of the line (either fully extended or fully retracted) the battery will be drained (even if fully extended or retracted does not means is locked). Do not risk just disconnect one of the two connectors. If not locked the motor receives continuously power and will drain the battery (you can hear a low clicking sound once every 15-20 sec, that is the bimetal safety switch connecting-disconnecting the motor). Also the wires and the motor are warm to hot during this time (that is your battery draining).

How to remove the antenna:
You need to disconnect the electrical connections (power and radio antenna), the drain tube and unscrew (no 10 wrench) the ground wire screw (topside) and the screw holding the antenna bracket to the body (lower side). Then slide the antenna down (to clear the rubber grommet). The antenna comes out from the trunk bracket attached.

Common problems to the antenna:
1. Burned Antenna fuse (20A trunk compartment)
2. Sticky antenna relay
3. Broken nylon wire lifting/lowering the antenna mast
4. Worn gears (motor shaft or plastic spooling wheel worm screw assembly)
5. Worn brushes
6. Burned/dirty locking contacts (part of the brushes assembly)
7. Sized motor shaft due to water intrusion
8. Burned motor

1 and 2 can be eliminated once the antenna is removed by applying 12V ([+] to pin A and [] to pin B to extend mast or [+] to pin B and [] to pin C to retract mast) on the small pigtail harness connector that goes from the relay to the antenna motor (to be seen in fig.1, is a 3 wires connector A White wire, B Green wire and C Gray wire). Never connect power between A and C (direct short)
If the mast is moving then either the antenna fuse is burned or the antenna relay is sticky or wiring issue on the car harness.
3. Can be detected easily by trying to manually extend the mast, if it extends then the wire is broken.
Any issue from 3 and down require disassembling the motor and gearing.

http://img79.imageshack.us/img79/2314/69230334.jpg
Fig. 1

In Fig.1 you can see the screw, clips and rivets holding the two halves of the motor assembly together. If the antenna was never serviced, from factory comes with rivets. You will need to drill the rivets out and replace with screws. In my experience inch long M5 screws with 2 washers are the best (you need 3).
Should you do exploratory surgery first, to prevent the wire from coming loose from the gear, leave attached the plastic piece shown removed in Fig.2.

http://img79.imageshack.us/img79/5790/33908595.jpg
Fig. 2

Drill the rivets, pop the 3 clips and unscrew the one T10 screw not holding the previously mentioned plastic piece.

http://img79.imageshack.us/img79/1614/45727977.jpg
Fig. 3

In Fig. 3 is the inside of the antenna mechanism with the cover removed. Please note the mast will come loose once the case is split (as seen in fig 3).
Inspect for signs of worn gears on the worm screw assembly. Replace the worn piece, if the shaft is rusted and worn then the whole motor shaft has to be replaced. The motor shaft comes out from the plastic casing after you take out the brushes/lock & safety switches assembly. Inspect the brushes if worn replace assembly. The stator (the big magnet shown in Fig. 3 should slide out (just magnetic force hold it over the motor windings).
The shaft can be borrowed from ANY Delco power antenna motor used in various GM models in the 90s. Fig. 4 is showing the stator.

http://img79.imageshack.us/img79/2420/72892180.jpg
Fig. 4

The stator can be reused (just slide-it in place over the rotor). Note on one side the stator has a small round rubber glued, that side should be on the bottom (the not seen face in Fig. 3). To slide the rotor in place squeeze the two locking switch actuators and lower shaft. Make sure the two bushings (acting like bearings) are oriented with the flat side UP. If the stator is rotated around the shaft with the wrong side up then the motor will spin with grinding noise, if the bushings are wrong side up the motor will spin slower (friction after tightening the two halves of the plastic casing).

http://img79.imageshack.us/img79/9950/79499962.jpg
Fig. 5

If is only the plastic wheel then disconnect the hook attaching the nylon wire to the wheel (as seen in Fig. 5) and replace wheel.
To attach the two halves of the case back together unwind the nylon wire and position the wheel EXACTLY as shown in fig. 6.

http://img79.imageshack.us/img79/6670/97169140.jpg
Fig. 6

Notice the notch called stopper, that notch can not be in the RED area. Can be positioned in ANY position around that green circle but better orient the wheel in the exact position shown in Fig. 6 with minimum nylon wire on the wheel (notice the hook that is the end of the nylon wire, less than of a turn).

http://img79.imageshack.us/img79/4260/44289387.jpg
Fig. 7

Observe the small wheel on the cover (see Fig. 7). Make sure the wheel is oriented in EXACTLY the position indicated (the missing tooth should be towards the red line). That wheel is what stops the antenna when fully extended. If the wheel is randomly oriented the antenna will not extend all the way.
Lubricate with grease all points indicated in fig 3 and the area around the little gear shown on fig. 6. Do not lubricate the cable or the mast.
Slide the brushes/switched assembly over the shaft (as seen in fig 6 highlighted magenta). If brushes are loose re-gap as required, then put the cover back along with the clips and screws (replacing the rivets). At the same time make sure the round gasket over the nylon wire (seen in Fig 3 and 6) is placed in the correct location.
ALWAYS do a bench test of the antenna; apply 12 V as described above. Allow the mast to travel from fully retracted to fully extend (several times). Very important, you should hear a distinctive click at the end of the travel (in any direction). If no click, the shaft does not slides (up or down) disconnecting the power to the motor. You can observe the shaft sliding up or down with the cover removed (as seen in Fig 2.). If no distinctive loud click start all over (something is not assembled correctly).
Hope this will save you $50 or so.

AMENCADDY
05-12-09, 12:09 AM
Thank you so much for this post. How did you know this is the exact info I needed too?

Yes, antenna will not retract and was all unplugged since I bought my car. Now I know I could proceed how to rebuild it but, I can not figure out how to remove the rubber nubby and bolt thingy on the exterior where the mast protrudes from. I've tried needle nose pliers, etc. but I don't want to damage it. Now I wonder if I even need to do that; does it just slip right thru there? Could you give me a clue, please? I have avoided this minor problem since the radio works fine but I'd like to get to it one of these days. Thanks in advance.

Talamant3z
05-12-09, 01:00 PM
great post im going to try on mine now it makes just the turning noise but doesnt left or pull down

Talamant3z
05-12-09, 01:05 PM
also it makes a bunch of clicking sounds really loud

C0RSA1R
05-18-09, 06:30 PM
WOW. This is a freakin' EXCELLENT post. Magnificent pictures, and thorough labeling and instructions. This is going right in my FireFox bookmarks. If my antenna ever breaks, I'm set - and so is everyone else, for that matter. Good work, N*Caddy, and thank you.

Texan4Life
02-24-10, 12:08 AM
great post I did the same thing for my antenna about 2 or 3 years ago because it was getting sluggish

BE SUPER careful with the flexible plastic "wire" on mine it was super brittle and broke. I now have an "always up" antenna, a down grade from a sluggish one.

keelerdr
03-03-10, 11:02 AM
I saw your post and figured I may be able to help. My power antenna stopped working a while back, stuck in the up position. I could hear the motor running trying to pull the antenna down w/no luck. I found out later that my white plastic cord/cable had broken.

I figured I had to spend the $200 or so for a complete new Delco unit from a dealer or get the universal Metra power antenna (crutchfield) and splice all the wires to make it work.

Well with some luck, I found a website that has what I need. Google "antennamastsrs" or click this link http://www.antennamastsrus.com and search for your car. Be sure to pick the correct piece you need. I only needed a new cable since my mast wasn't bent/broken AND my motor still worked. The install takes some time but it is doable as long as you understand how the mechanism works. I replaced mine last night, took longer than needed (I stripped the black 14mm plastic nut thing that is on the outside of the car at the base of the antenna)

To replace the white plastic cable, all the disassembly you need to do is up to Fig. 2 above.
You can also send your unit to them and they'll install the cable for you. Hope this helps.

Napes1
05-25-10, 09:30 AM
I have a "vintage" 1969 Deville with the antenna stuck in the "up" position. The motor works when I press the up or down button on the radio, but all I get is a "clicking" sound with no movement of the mast. I'm guessing the nylon cable is broken or detached. Is there a trick to getting it to retract so I can remove the assembly for repair?

tateos
09-20-10, 07:02 PM
Excellent post with pics - worked out great - thank you N*Caddy!

wedgewa
10-23-10, 01:22 PM
This is really well done - but mentions removal from the trunk.

Any guidance available on removal from the right front fender? There doesn't seem to be any easy access. (88 Deville)

I have a replacement internal cable ordered.

Ranger
10-24-10, 10:15 PM
Each car is a little different. A little investigation should tell you how to unbolt it. You will have to remove the decorative lock nut at the base of the mast, but it should come with instructions. Follow them to the tee.

wedgewa
10-24-10, 11:42 PM
I found some info on removing my 88 Deville antenna from the right front. There's nothing to work with from the top except one screw sideways under the hood. The rest is under the inside of the fender accessed by first removing the wheel and the fender liner. Kind of looks like getting it out of the car is harder than fixing the unit itself. But the repair part has arrived and it will be done soon!

Trulytex
12-03-10, 11:28 PM
Doing this tomorrow to my 87 Allante'. I got the cable from Allante' Source.

BGG

Hairball
12-09-10, 10:10 AM
So, this brings me to a question since you're obviously a power antenna EXPERT. Yep, only an expert would go through all this stuff you posted!

My Scenario: the stereo isn't hooked up (I removed the Kenwood someone put in), and all the wiring harnesses to the OEM deck were cut and the power antenna wire vanished (probably just fell in the dash). I still can't get over the fact that some idiot cut the original harness!!! They also added one of those window-mounted universal antennas. Not sure if they did it because the power antenna didn't work or they couldn't find the cable or they cut it like they didn't everything else!

But my question is: How do I get the antenna to go all the way down? I can move it up and down by hand easily enough, but it won't go all the way down. At it's lowest point, it still sticks up about 3-4 inches. I'd just like it all the way down.

Any way to get it all the way down until I figure out later if it actually works or not?

Jim 99 eldo
02-15-11, 11:26 AM
When you hear a clicking sound when the antenna is running and it is not going up or down the problem is going to be the plastic line is broken at the metal hook in the winding part. Mine broke right at the metal hook I fixed it like this I pulled the metal hook out and put it in a vise them with a small torch I applied heat this caused the plastic inside the hook to melt and flow out like water "Bam!" Hook is now empty then their is a little dimple were the factory dinged it to hold the plastic secure a correct size drill will smooth out the dimple on the inside of the hook using you old plastic line insert it into the hook and them using a punch replace the ding dimple to secure it to the hook. Reassemble lube every place N* Caddy suggest and you are good to go.

CUTiger78
01-08-12, 01:47 PM
Help!

Bought the antenna mast & cable from AntennaMastsRUs and everything has gone OK, but I can't for the life of me figure out how to get the cable hook back where it belongs. I think I know where it should go - at the flat spot - but I can't get it to hook into anything.

Any ideas?

Thanks!

Ranger
01-09-12, 09:29 PM
It's a little tricky, but it hooks into the little hole in the gear.

sacvo1999
03-18-13, 04:54 PM
any good ideas on places or companies that sell the mast

Ranger
03-19-13, 09:24 PM
http://www.antennamastsrus.com

cbheart
03-24-13, 06:58 PM
Retractor cable was broken, but mast was okay. Ordered replacement cable without new mast for $25. I then followed the instructions above, including all the very helpful annotated photos. Everything proceeded exactly as described in the narrative. What a great site, and what great advice in this string.

Thanks for the meticulous job.

David Biarritz
06-05-13, 10:06 PM
I just repaired the antenna on my 83 Fleetwood brougham coupe. This was very tricky and obviously was not designed to be repaired.
This model has only a very small access, lower half wheel housing. Too small for the antenna with the mid-mounting bracket.
It is not explained how to remove the antenna on the Fleetwood anywhere in the 1983 Cadillac service manual. Only for the Eldorado and Seville.
And if you did manage to remove the antenna, you will find that the new antenna or mast is not available for this model.

This is how I repaired mine. Just turn the steering wheel full lock to the right.
Remove three lower screws from the wheel arch mould and under that the two T30 double hex fender bolts that secures the plastic lower-half wheel housing.
Now using two large screwdrivers or twisting a chisel, pry apart the two plastic plugs that clamp the lower-half wheel housing to the upper-inner wheel housing.
With a torchlight you can now just see the antenna.
Remove the two top mast bolts at the top of fender, just under the hood and the mid-mounting 10mm bolt down in the engine bay (no need to remove the escutcheon assembly at this stage)
Disconnect the antenna connection and three wire feeder plugs.
The antenna should now drop down, but you will not be able to remove it out of the access hole unless you remove the mid-mounting bracket using a 10mm socket and small ratchet reaching up inside the access hole.
(My antenna was stuck in the 'up' position which meant I had to also drill out the rivets; remove the clips and remove the mast. In hindsight I would have been better to just cut the mast.)
Most common problem with an electric antenna is that the plastic tail will be broken.
Not being able to find the exact antenna new or second hand, I managed to find a Seville antenna of the same year, but the mounting brackets were not in the correct place.
You will find that the inner mast's are interchangeable.
With the new working antenna, you can drill out the rivets; remove the outer clips and take out the mast (including the plastic tail and gear complete).
The centre of this mast can be removed from the outer mast by unscrewing the white plastic inner part of the base of the mast.
Disassemble the old antenna the same way and install the newer inner mast to the outer. Assemble the motor housing using nut and bolts instead of rivets. You can bench test using a 12 V battery.
Now comes the tricky part; to mount it back into the car, insert the antenna into the access hole and reach in and connect the mid-mounting bracket using a 10mm socket and ratchet one handed with your eyes closed and it has to be attached the right way around.
Feed the antenna and connection plug though the feeder hole.
Remove the top escutcheon assembly and use a stiff wire from the top to hook up the antenna mast; lining up the two top mounting bolts. Don't tighten at this stage.
Now try to align the mid-mounting bracket and insert the last bolt from the engine bay. If this is successful, tighten all the bolts. You may need a 10mm open end and keep the antenna up so that it wont foul with the top escutcheon assembly when the antenna is in operation.
Reassemble the lower-half wheel housing cover and reconnect the antenna and connecting wires.
I hope this guide will help anyone else with a similar problem.

madmaxwolf
03-17-14, 10:33 PM
Thanks so much for this post. I bought a 1999 DeVille Concours back in July and the antennae was stuck in the where ever I put it position (I guess the plastic cable is broke as the motor runs). I pulled another intact antennae assy from a 97 in the local pick and pull for $20 and installed it. It only went up about a foot. I waited till today to again remove the working one, disassemble it, clean it, grease it, and align the plastic wheel and the little stop wheel and bingo-bango, it works great. It had never been serviced. How long should it take for the antennae to extend/retract? Mine is 5 or 6 sec. Now to take the broken one apart and see if I can fix it too. Nice to have a backup if ever needed. Again thanks.

Fred Kiehl
06-05-14, 09:11 AM
The pictures have disappeared from the post. What is the position of the stop for the drum?

Bigmccc
08-07-14, 11:41 AM
Great info, I used it a few months ago to replace my antenna. The car wash necessitated me doing it again. however now the photos are gone from the post..if you see this, can you repost if you still have it please.

Thanks

fishnazi
08-09-14, 01:51 PM
I second that request for the pictures! I swapped a mast and cable from a salvage yard find into my antenna motor. Only problem is that I can't get it to raise the mast. It will lower it, but the motor doesn't even hum when the mast is already down. And that's hooked up to the car with the radio turned on! Madmaxwolf, do you have a picture of "the little stop wheel?" I don't recall seeing anything like that in either motor.

Ranger
08-09-14, 08:36 PM
Sit tight guys. N* is on a trip around the U.S. right now. Probably got another week or two before he even see this. Whether or not he still has the pics is another story.

I'll PM him to have a look here when he gets a chance.