: The Good and Bad of my last Dealership Visit



supernova_inc
05-01-09, 01:11 PM
I took my 05 in for a front end shifting noise I was hearing going over any large road crack or speed bump(very slow speeds). This was the second trip in for the issue. The service rep has been very good about listening, advising me on his time frames, and arranging me a rental(they no longer use loaners) The first visit they replaced both front struts and strut mount plates. When I picked up the vehicle unfortunetly my adviser was not in but the problem was still evident.

The second time they took the vehicle to inspect a couple other areas then gave it back to me while parts were ordered, if any were needed. The dealership believed the problem was with the lower ball joint, which are serviced with the lwr ctrl arm. They ordered two new lwr arms, and two stabalizer bar bushings. I dropped the vehicle off this last wed mid day and picked it back up yesterday. After pickin up and testing it out I was extremly happy. The suspension was definitly more firm and secure feeling with now odd shift any more. I was very pleased that the dealership kept on the problem and did not give me a answer of "thats part of the vehicle design," or" that is normal for this vehicle." They also replaced a LR window switch as it had gone out. The regulator was fine but my passengers could not roll down the window(I did check child lock,and window lock out previously)

My only complaint came when I was driving the vehicle back to work. I travel on the freeway some and at normal freeway speeds there was a very different tire noise that I had never heard before. It was a noise from the contact of rubber to the road itself. It appears as though the vehicle was not given a two wheel alignment after the new lwr arms were replaced. Now I know my old arms were not bent as I had my vehicle aligned within the last month and I have not curbed anything since owning the vehicle nor smacked any pot holes. I know the toe appears ok as that is adjusted through the tie rods but I was thinking the camber now may be off. I have my local shop doing a quick ft alignment check for me now to verify but I am pretty sure this is the culprit.

Considering everything the dealership replaced, which I know can be considered wear and tear(strust etc) I am still very pleased with the level of care the dealership provided me and this noise is not costing me anything to verify my alignment specs. Just wanted to voice my recent experience here in NM.