: (another) Fuel Gauge Problem...



SRT ACE
04-27-09, 05:56 PM
Hello All,

I wanted to take a minute to post about a problem we just started having and hopefully gather your expert advice/suggestions. I've read a couple threads on this already but wanted to post up my specific items. We are still in the first couple months of ownership of our 2004 V6 AWD with ~65k miles; my wife is the primary driver.

Incident #1
My wife is a nurse and is currently working a 3p to 3a shift. I was home sleeping one night a about a month ago (so my memory is a little sketchy) when she called saying the car died. She started it, backed it out of her space, and started forward when it cut out. She tried to start it a couple times to no avail. She also had one of the hospital security guards try to give her a jump, also to no avail. I picked her up, tried to start it a couple times myself, and then decided to leave it in the hospital parking garage. It was turning over but sounded starved for fuel/spark.

The following morning, after talking to my wife and some reading of the forums, I decided that it had probably run out of gas. We filled up the 5 gallon container and headed back to the hospital. Before starting it I noticed the gauge read roughly 1/8th of a tank, the trip was ~370 miles, and the fuel used was 19.0-19.5 gallons. I poured in the gas (all five gallons) and it fired right up. I drove it down to the gas station and it took roughly 14.7 gallons.

I advised my wife that there was probably problems with the gauge and created some "rules of thumb" to prevent it again - get fuel soon if mileage is 300 or fuel used reads 17.0 gallons. Figured this would be a temporary bandaid until I resolved the problem...

Incident #2

This brings us to yesterday. Last Sunday (2009-04-19) fuel used read 17.0 gallons and I filled it up with 17.3 gallons (during the fillup I reset all of the applicable DIC readings). So I used this as a check (obviously with an enormously small sample size) that the fuel used was working appropriately. Wouldn't you know it was after this fillup where we found the hard way it in fact does not. After driving to work a couple times during the week and a few other errands we packed up the car to head down to Ocean City, NJ for the weekend.

Packed up on Sunday afternoon and started to head back. I was driving and knew leaving we were due to get gas soon. When we left OC, NJ all of the "rules of thumb" were pointing to not needing gas immediately (mileage roughly 220, fuel used roughly 12ish). We were on our way and just getting off the highway to get gas when the car died. The gauge read 1/8th tank, 286 miles driven, 15.5 gallons used, and roughly 60 miles till empty). Luckily the gas station was ~0.1 miles away (which I walked) and after five minutes of waiting somebody pulled in who was filling some gas cans. The good samaritan drove me to the car and gave us roughly 1 gallon. Car started right up and we proceeded to the gas station. The car took 18.96 gallons at the fillup.

So, here is where it gets more interesting. I just calculated how much driving we did on that tank of gas and, at a minimum (all the trips I could remember), we traveled roughly 315-320 actual miles (and not the 286 the trip read). All though I would have been pissed if we actually got only 14.3 MPG (mostly highway in warmer weather) I am more upset to know the trip odometer and other DIC readouts cannot be trusted now.

Incident #3

This was actually the first incident chronologically but I didn't read too much into it at the time; I'm including it as another example. It was roughly 1.5 months ago. We were leaving a birthday party when we realized we forgot something. Another family member was leaving not too far behind us so we decided to pull into a gas station and wait for them; thankfully (hindsight) we decided to get gas as well. I don't remember the gauge reading (all though it wasn't too low) or the DIC readings. The car took 20.2 gallons of gas. We didn't have the owners manual with us but I confirmed later that night the capacity was 20 gallons. Chalked it up to a bad pump and moved on...

Thoughts anyone?
Any cause of the DIC resetting on its own?

Thanks for any help/comments/suggestions in advance.

Best,
ACE

Superjim
04-30-09, 12:11 AM
First thing I would do, is not let it get below 1/4. :stirpot:
Second thing is to run 2 or 3 cans of Techron thru it.
You may have some deposits on the the sending unit in the tank and the Techron will possibly clean it up for you and make the gauge more accurate.

Personally, I never run mine much below 1/4.
Don't want to take the risk of running out of gas.
It ain't worth it to try to stretch the mileage to the LAST OUNCE of fuel in the tank.

Just my opinion.

Texas Jim

USAFRET
04-30-09, 05:31 AM
First thing I would do, is not let it get below 1/4. :stirpot:
Second thing is to run 2 or 3 cans of Techron thru it.
You may have some deposits on the the sending unit in the tank and the Techron will possibly clean it up for you and make the gauge more accurate.

Personally, I never run mine much below 1/4.
Don't want to take the risk of running out of gas.
It ain't worth it to try to stretch the mileage to the LAST OUNCE of fuel in the tank.

Just my opinion.

Texas Jim

I echo Texas Jim's comments. Don't rely on the DIC alone, use the fuel gauge. Corvette's have experienced the same issue since the C5 came out in 1997. GM published a TSB on it. I experienced it on my 99 and 03 Z06 as well as my current 2006 Corvette.

Run a bottle or two of Techron for the next couple of tanks of fuel. Also the fuel you buy can cause this faulty DIC readings so buy quality Top Tier fuel.

But don't let the fuel gauge drop below 1/4 and you will never be bothered or stranded.