: Help! Keyless entry reprogramming for '04 srx



randyfield
04-23-09, 11:52 AM
Does anyone know how to reprogram the keyless entry system for an 04 srx? I found a thread from a while back, but seems like it was steps to follow if you DID NOT have the Nav system.
The battery is good, tested it yesterday.....I would hate to have to take it in and pay for someone else to hit a series of buttons and fix it.

HELP?!?

thunderbyrd01
04-23-09, 03:42 PM
i have just went through this 3 days ago and I am happy to share my experience. I have a 2005 White Diamond SRX 3.6. A little background first : I have owned a Mazda Millenia & a 05 Ford Explorer and the Mazda came with a bad remote and the Explorer on had one. For each one I bought an extra remote from Ebay. Programming them was easy. The instructions were simply pressing a couple of buttons on the remotes while turning the ignition switch on and off several times. However, Our Cadillacs have to use something called a tech two tool to program the remote to the car. I understand some locksmiths even have this tool. Believe me I tried and researched everything I could to find a way to do this myself: I didnt want to take it in for the same reason you stated. I've came to the conclusion that I cannot program it without this "tech two" tool. (a very expensive piece of equipment) I have not taken it in yet. On a similar note, I purchased a blank key from my local dealer (these keys have a transponder inside them) and I had it cut, now I was able to program the key to the car myself, its very simple. But as bad as I hate to I will have the dealer or locksmith program the remote. Good luck, and post your results or anything you find out about your situation. I hope this helps.

randyfield
04-23-09, 04:27 PM
Well, crap, that wasnt what I wanted to hear! How much did the extra key cost you? The other key to ours was lost by the previous owner, so now I'm stuck if this one ever gets lost.
Here's my story with the keyless remote.....
Took the car to have an overhead dvd system installed, long story short, they were able to because the had nowhere to mount it...apparently, SRXs do not have a cross bar running under the headliner between the front doors. Picked up the car, got home and discovered that the keyless remote no longer works! Called them back and they said that there was nothing that they would have touched or disconnected or anyhting that would have cause it to stop working. As I said before, I have replaced the battery, TRIED what I had found in the other thread about Keyless entry......just seems a little coincidental that when I dropped the car off for the dvd install it was working and when I picked it up is wasnt working!