: Unusual Howling noise.



MYCADDY
06-24-03, 07:07 AM
Hey guys, Im looking for some advise or any suggestions. I have a disturbing howling noise comming from underneath the left side of the front valve cover or the in the pulley system by the alternator area. Has anyone had this kind of noise comming from their northstar engine? Its pissing me off that a engine with 57500 miles on it is making this kind of noise. Your replies are greatly appreciated.

Thanks

Matt

Katshot
06-24-03, 08:28 AM
Hey guys, Im looking for some advise or any suggestions. I have a disturbing howling noise comming from underneath the left side of the front valve cover or the in the pulley system by the alternator area. Has anyone had this kind of noise comming from their northstar engine? Its pissing me off that a engine with 57500 miles on it is making this kind of noise. Your replies are greatly appreciated.

Thanks

Matt

As memory serves, that would be a waterpump/drive issue.

HotRodSaint
06-24-03, 08:53 AM
As memory serves, that would be a waterpump/drive issue.

Or you hit a dog! :eyebrow:

MYCADDY
06-24-03, 11:15 AM
The noise does not appear to be comming from the water pump. I belive that the water pump is on the otherside of the engine. The nosie started when i let the car sit for a while.

Hit a dog :rofl:

MYCADDY
07-12-03, 03:38 PM
Well i fixed the problem after replacing alot of stuff. I first replaced the P.S. pump, not it. 2nd Tensioner, not it. 3rd idler pulley, nope. Then last but not least the alternator, :wacky: that was it. The bearnings were all bad and it sounded horrible. So now that i spent about 275 buck in new parts that will probably needed to be changed in the near future. I did all the work myself also, it wasnt as bad as i thought it would be. I guess thats better than 500 or so that i would have had to pay at the stealership. Later

Matt