: 2000 STS Blowing Oil but Can't Find It



rdpjr26
04-07-09, 12:40 PM
I recently purchased my wife a 2000 STS very nice powerful car. We have had it since Christmas and have had no issues. 3 Weeks ago the low oil light came on. Whebn I checked it IT WAS EMPTY. I had to put 5 quarts in it to get the light to go off. Went out to check it last weekend and found it was a quart low again and I guess I did not notice it before but the insulation blanket under the hood was soaked with oil. I could not find any iol on the motor itself as well as no drips underneath. Took the STS into the repair shop and they cannot find ANYTHING WRONG!!!! They went all over it and could not even find any oil drop anywhere. WHERE IS IT COMING FROM???/ Has anyone else ever expeirienced this???/?? Nothing underneath checked oil cap, dip stick and pcv valve all good. THere is literally NO OIL ON ANYHING!!!! Please help

VortecCaddy
04-07-09, 01:40 PM
I am going to assume that this is a legitimate post. You say there is NO oil anywhere, the n say that the hood insulation was soaked with oil. Maybe the oil cap was off or loose. It is hard to believe that you are loosing a 3 quarts of oil and there is no oil anywhere to be found. It is possible that it is leaking oil into the combustion chamber but you would have major drivability issues.

rdpjr26
04-07-09, 02:35 PM
This is a real post. There is NO OIL ANYWHERE. It is the crazyest thing ever. No oil around the intake, no oil around the plugs or the coils, pcv valve is good, all hoses look good. The only part of the hood insulation that is dry is on the driver side towards the windshield. Thanks to all for looking!!

Submariner409
04-07-09, 02:37 PM
This belongs in Seville or Northstar Performance.

There is a very large world of difference between 5.0/5.7 engines and the Northstar.