: Alternator questions....



Cleaner1974
04-06-09, 03:31 PM
I've searched the forums a few times and found some information on changing the alternator on a N*, but haven't found exactly what I am looking for...

1996 Eldorado ETC 175000 miles (no oil leaks!)
The car was making a squealing/grinding sound coming from the front passenger side engine compartment...The noise stopped and a "Battery No Charge" warning showed up on the dash, so I figured it was the alternator.

I removed the passenger side wheel and removed the access cover to reveal what I thought was the alternator, but I now think it is the a/c compressor. I believe the alternator is located a little more toward the front of the car, but am not entirely sure. I also do not know where the belt tensioner is located. I read one post that says I have to remove the radiator to get to the alternator...I refuse to believe this.

Since I decided to quit my well-paying job in sales and pursue my dream of becoming a teacher I have become somewhat of a shade tree mechanic. If I had some pictures and/or good advice or instructions I think I could change this puppy out....I've changed alternators before, but this thing is hiding from me:) Help! Thanks:)

Rick

Ranger
04-06-09, 04:57 PM
Yeah, you're looking at the compressor through the wheel well. The alternator is where you suspect and I do believe you will have to remove the radiator from what I have heard. Never had to do it yet so I can't speak from experience. The tensioner is up top.

Mark C
04-06-09, 06:47 PM
The alternator is above the a\c compressor tucked in next to the exhaust manifold. There is one bolt on the bottom front of the alternator (right under the pulley) and two bolts in the back, one just inside a notch in the exhaust manifold (its a short bolt so don't loose it or mix it up with the other 2) and another further back behind that one. You have to remove the plastic lower cover between the radiator support and the front edge of the cradle to get at it from below. If the eldo is the same as a Seville there is a small removable section of the lower radiator support about 6" square that you take out to lower the alternator out without having to remove the radiator. It drops out vertically thru that opening, ie the pully facing up or down and just barely fits.

Cleaner1974
04-07-09, 12:54 PM
ok, I havent got to slide under the hood since I posted this, but just so I am straight...When you say "up top" you mean the big pulley at the very top right? heres a pict.

http://img49.imageshack.us/img49/9935/img0045.jpg

the one by the power steering filler?

thanks.

Ranger
04-07-09, 01:03 PM
I can't tell from that picture, but the tensioner pulley is not too big. Do a search for it. Someone just posted a picture of one not long ago.

Cleaner1974
04-08-09, 05:11 PM
cool will do tonight...i slid under the hood last night and didnt see any access panel...will take better/more picts in the next few days...not gonna be able to work on it until weekend though.

tateos
04-08-09, 09:32 PM
There is an access panel held on by 4 bolts on the passenger side - you remove the bolts and panel from the bottom. I tried this the first time when I replaced the alt on my 97 ETC, but could not seen to remove the alt out the bottom and ended up removing the fans and radiator. I need to replace the alternator again - I will try taking it out with the pulley facing up or down, but please let us know if that works for you. Thanks.

RM

Cleaner1974
04-08-09, 11:40 PM
lol yeah...I found all the bolts and the access panel...i removed the long plastic panel and the smaller one on the passenger side...there are 2 bolts in the back...one didnt come all the way out, but the alt fell off after i removed the other two bolts from the front...three short bolts and one long...having the same problem as you with letting it fall out the bottom...messed (not the word i wanna use) with it for about an hour rotating it this way and that...still gonna mess with it some more when i am off friday...gonna cuss a lot on good friday...oh well:) what sucks is i just had the radiator replaced last summer:( shoulda thought about some preventative maint. then...it looks like i could loosen some bolts on the air comp and maybe then i would have room...i just looked on the forum about radiator removal...doesnt seem too hard...wish me luck!

rick

Cleaner1974
04-10-09, 03:54 PM
I didnt have to remove the radiator! I just took the long rad hose off the rad and then undid the passenger side fan, moved it over to the drivers side a little and the alt just fell out! I'll post step by step and picts when I get the alt back...its being rebuilt as we speak.

chubbyranger
04-12-09, 08:15 AM
Sounds like a good opprotunity to change your coolant as well if it hasn't been done in the past two years.

ewill3rd
04-12-09, 09:00 AM
Spin the pulley on the compressor before you go to the trouble of replacing the alternator.
Sounds to me like the compressor went bad and caused a drive belt issue.
Is the belt still intact?
Some cars have a small access panel below the radiator that you can remove to sneak the alternator out.
You do have to remove the radiator on some models, but be sure you have to before you go to all that trouble.

97EldoCoupe
04-12-09, 10:53 AM
Feel lucky it's not a 98+Seville you're working on.

Cleaner1974
04-13-09, 01:34 AM
after driving it the past couple of days I still have some problems...the squealing sound stopped, but still get the "no battery charge" error on my dash....but not all the time...when i first crank it up the error will pop up, but when i gas it a little it will go away...off and on for about ten minutes...after about ten minutes it will stop completely and hold at 12.8-13.00 volts...sometimes it will go as high as 14 volts...maybe a slipping belt? atill gonna post picts of entire process...been busy...will do it at work:)

chubbyranger
04-13-09, 07:01 AM
You may have a bad belt tensioner, bad battery or both. Dying alternators can take out the battery. Take the car to an auto parts store and have them test the charging system and battery. Most stores will do it for free.

Cleaner1974
06-14-09, 02:03 PM
ok. The alt went out again so I pulled it and had them rebuild it again. they told me the voltage regulator went out...I took the alt by a Oriely and thier machince said it was good to go. I put it back in and the alt isnt doin a thing. Check charging system error pops up. The car will run for a few mins but the battery quickly is drained and the car starts sputtering lights dim and dead...any other suggestions.

Ranger
06-14-09, 05:24 PM
Is this the original alternator?

ewill3rd
06-15-09, 09:00 AM
Did you charge the battery? You can't put an alternator on a brick and expect the car to work.
Don't charge a battery with the alternator, that is how you fry an alternator. Get a full charge on that battery and test the system properly. Maybe the problem could be the battery. I think OReilly will charge it and test it for free if I remember right (they dont' have them around here).

Cleaner1974
06-15-09, 11:35 PM
yes orig alternator, just rebuilt.

battery fine. fully charged. etc etc

as it turns out, the voltage regulator connector was disintegrating. i unplugged it a couple of times and on the last try it broke into three pieces in my hand. i went back to the auto parts store and got a new one. it was a 3 wire and the orig was 2. i used the two skinny wires on the new plug...taped it all up, and everything has been good to go.