: No one can figure it out!!! Help!!!



redlac
07-07-04, 06:06 PM
I have a high idle problem with my car. Even when I put it in nuetral it goes up higher. I have replaced a bunch of stuff myself and told that I did them right(but maybe not reset right), not sure. So yeah nothing helped. I had it looked at by a GM certified garage,...still nothing. They say they are not sure and they could start here or there. It's hard to come to a full stop especially with the AC running.
Also while on the highway at 70mph, my tach reads about 2300rpm's, and I know that is higher than it used to be. It used to be around 1800rpm's. Also at about 85 it reads about 2700rpm's. That is just way to high and that used to read about 2100rpm's.
The pick up is not what it used to be either.
Is it possible that bad injectors would be the problem?
If anyone on here can figure out what the deal is with my car, let me know and if you are right and it fixes it, let me know who you are and where you live and I will reward you for this(no lie).

JimD
07-07-04, 06:25 PM
What year model??

Can you retrieve the stored trouble codes (DTC's)??

redlac
07-08-04, 05:38 PM
It's a 95' sts. The funny thing is,.. is that there are on codes being sent when this happened or even now. I have had stuff happen in the past with codes and checked them myself and fixed them but this one is a pure mystery. It was never a slow process either, it just happened as i started my car one day,...really high idle. Oh and my previous car of which was a 92' seville had the same exact problem but forget that i guess. I know it was wrong of me to do this and I stopped, but I deliverd pizza's in my car a lot and the day before this happened I noticed while pulling up back to Pizza Hut that my coolant temp was high, about 228 to 232 which it should never be that high. So anything to do with this might help anyone figure it out.

bbozsik
07-09-04, 12:05 AM
Search for two things on this forum. Cleaning and servicing the throttle body, and checking proper operation of the Idle Speed Control motor. I almost guarantee it's one of these two problems. Good luck

To clean the throttle body, remove the air cleaner housing and "big black hose" that connects to the TB. Wedge the TB blade open, and you should see that it, and the surrounding interior of the throttle body are black with built up carbon residue. Use throttle body cleaner, an old toothbrush, and a shop rag to clean the blade and interior of the throttle body until you can see metal again. Be careful not to spray too much cleaner at any one time, or you may get too much gunk into the engine.

To check the ISC motor, with the air cleaner and hose off, turn the key "on" but do not start the car. Enter onboard diagnostics by holding the "off" and "warmer" buttons on the climate control system for a few seconds. When you receive the "PCM?" prompt, press the "up" button to select PCM. Then press the "down" button until you get to PCM Override?. Press up to select this and press down until you get to PD04. The climate control display should read "50" pressing the cooler button will retract the ISC motor to it's fully retracted position. At full retraction, there should be a gap of about pages of paper between the blade and the ISC motor. If not, the 8mm (?) bolt of the end of the motor can be turned back.

Please, search for more answers and better directions from the members of this forum. BBobynski has posted many great ideas and directions on the correct was to do all of this, so anywhere you see his name connected, you will find a very specific answer. Many of the people on this board know these Northstar engines inside and out. You're at the right place.

maydog
07-09-04, 12:20 AM
I would guess you have some sort of vacuum leak and 2700 rpm's at 85 sounds about right for a STS.

redlac
07-20-04, 01:57 AM
If I were to have a vacuum leak, where should I look to see if this were the problem? Basically, which hoses might these be or which gasket might need to be replaced? Anything more would be great!!!!!!
If I can fix this, I seriously would be the happiest person ever!!! So far it has been like this for a year.
Thanks to whomever would like to help my sorry *ss out.

maydog
07-20-04, 10:27 AM
I have heard that you can use an unlit propane torch to locate vacuum leaks. Open up the valve and spray propane around the running engine around seals, etc. an listen for changes in idle quality. Be careful around hot surfaces and sparks.

I haven't tried it personally, but it may be worth a shot.

cadillacstars
07-20-04, 09:06 PM
sounds like a vac leak. propane works best, but so does brakkleen, carb clean..... any flammable liquid. spray it around, especially where the intake meets the head. listen for the star to idle down. that will be your leak.

BeelzeBob
07-20-04, 11:35 PM
uh...why spray flammable liquids around on the engine....???...and things that can eat off paint and wire insulation. Carb cleaner, propane and such are like looking for a gas line leak with a cigarette lighter...LOL.

Use a spray bottle with water and squirt around gaskets and seals and such. You'll hear the water suck in and the engine change pitch when the vacuum leak momentarily seals (due to the viscosity of the water) when you get near the leak.