: NO Codes but stalls...



02CadiDevi
03-20-09, 09:33 PM
I know you must see this stalling thread all the time, but one thing I found interesting is that even after it stalls I never get any codes to indicate an issue relating to this problem... I purchased the car about a month ago (02 Deville base model) and until I replace the fram standard air filter with a K&N drop in unit it didnt stall. But then again I replaced the fram filter almost right away...

I notice that it stalls only at start up (not at every startup) and when it starts with a rough idle. The RPMs go all over the place and some times it saves it self from stalling I see the RPMs go as low as 400 and then it pulls right back up to 650 or so... It doesnt happen all the time but I can tell when its going to happen as soon as the car starts its idle....

At first I thought the CPK sensors from other listings on the board, then after thinking about it seems like it may have to do with the intake sensors. I saw people talking about "relearning" do the sensors actually relearn? I am not convinced that its the CPK, but since I dont see any codes I am not sure where to start, any help is good help, thanks...

On a side note, nice forum...

Ranger
03-20-09, 09:57 PM
Start by checking for a vacuum leak at the plenum. Do a search for it. Pretty common. Then clean the TB.

JimD
03-20-09, 09:58 PM
... I purchased the car about a month ago (02 Deville base model) and until I replace the fram standard air filter with a K&N drop in unit it didnt stall.
Clue #1.

You say "NO Codes"; how are you reading the codes? The engine behavior you are describing should (eventually) set a code. Here is how to display trouble codes on your DIC:
http://www.cadillacforums.com/forums/cadillac-tech-tips/55172-how-pull-codes-got-codes-warning.html

If that K&N filter is oil-wetted, remove it and install a dry paper WIX or ACDelco filter. And then figure some non-intrusive method of removing the K&N filter oil residue from your MAF (Mass Air Flow) sensor.

02CadiDevi
03-22-09, 10:16 PM
I am not stupid I have researched the code look up before posting but still no code... Looked at the TB and sensors today and they are as about clean as stock I am telling you this car is almost new, clean as can be... I replaced the K&N with the fram filter today and just tonight as I went up the street to CVS the next time I started it, it stalled. NO codes still, not sure where to look for vac leaks, any help?

AMENCADDY
03-22-09, 10:41 PM
Under your hood somewhere obvious is probable a detailed diagram of where all your engine vacuum lines run. Check them visually for cracks and general damage. I think the following post I read earlier might also help even thou the guy had some codes. Here is the link

http://www.cadillacforums.com/forums/electrical-technical-information/163260-repeat-codes-diagnose-steps-advice-sought.html

JimD
03-23-09, 12:15 AM
I am not stupid

Did someone here accuse you of being s.....? If so, I missed that post.

AMENCADDY
03-23-09, 01:01 AM
Hey WEIRD! I just realized that in my previous post to 02 here, the link I gave had info from you JimD. What a quinkydinky! So doesn't the N* have a symptom section for Intermittent Stall-No Codes ? I know my FSM does but it's a different engine. I just did a whole post for the 91 Deville with the same problem.

Here:
http://www.cadillacforums.com/forums/cadillac-deville-1985-2005-including-1985/163851-91-sedan-deville-stall-3.html

:yawn:

02CadiDevi
03-23-09, 04:53 PM
FINALLY A CODE & check engine light :)

P0106 - Manifold Absolute Pressure (MAP) System Performance

So now what?

Ranger
03-23-09, 09:17 PM
Replace the MAP sensor.

02CadiDevi
03-23-09, 09:19 PM
Thanks, and will do tomorrow, will let you know results, thanks again...

02CadiDevi
03-26-09, 12:57 PM
Replaced the MAP sensor, car hasnt stalled but I will keep my fingers cross, one thing I did notice is the car seems more responsive while accelerating. If it stalls again I will let you know, thanks everyone...

02CadiDevi
03-30-09, 09:15 PM
OK, she stalled again... SOOOO, I noticed the throttle cable was a little on the loose side when I replaced the sensor, so I think I will try to adjust it tomorrow (will look it up in the book I got on the car) but no new codes showed up, so it could be a number of sensors but I will tinker with the throttle cable to start, any other words of help would be great, thanks...

Ranger
03-30-09, 09:24 PM
Throttle cable should not cause a stall.

02CadiDevi
03-30-09, 09:44 PM
Throttle cable should not cause a stall.

Ok then what should I look to do? I dont have a code to go on sooooo.... I know from my previous cars (late model hondas) that you could adjust the cable to the desired RPM at idel which was perfect for drag racing, as Ii stated before the Cadi is super clean just amazes me that its still stalling, I did notice the many intake related sensors... What are your thoughts, thanks... Seriously input that doesnt help isnt good, just a thought...

Ranger
03-30-09, 09:53 PM
I can't tell you from here. I don't know if it is an ignition failure or a fuel delivery failure. Could be many many things. It seems to be intermittent so that probably would rule out a dirty TB. IAC valve should set a DTC. Perhaps an intermittent fuel pump failure. I CAN tell you that the cable is not the problem though. You could cut the cable and it would not affect the idle.

02CadiDevi
03-30-09, 09:53 PM
Let me also restate the issue, the stall only happens at idle the cars RPMs dip below 650 RPM which look to be the min. normal RPM rate and then she stalls. I am hoping someone will have some good input. Stalling happens once in a while, since replacing the MAP sensor it hasnt happened for 4 days... Lets see what the only good Cadi forum on the net can do...

Ranger
03-30-09, 09:57 PM
the cars RPMs dip below 650 RPM
That kind of sounds like an IAC valve, but I hate to tell you to start throwing parts at it.

02CadiDevi
03-30-09, 10:03 PM
That kind of sounds like an IAC valve, but I hate to tell you to start throwing parts at it.

Hey man, at this point I am ready to replace anything to get her riding as perfect as she should, it has over 75,000 miles on it so I am sure things need replacing, I will inspect it tomorrow, thanks for the positive input...:thumbsup:

02CadiDevi
03-30-09, 10:11 PM
That kind of sounds like an IAC valve, but I hate to tell you to start throwing parts at it.

Your input seems correct as my basic research shows (below) that our moderator knows his sh*t...

How Does an Idle Air Control Valve Work? (IAC)

An IAC (idle air control) motor is designed to adjust the engine idle RPM speed by opening and closing an air bypass passage inside the throttle body. The car computer or ECM (electronic control module) receives information from various sensors and will output signals to adjust the IAC motor in or out to adjust engine idle speed by controlling engine idle air. An IAC motor can fail one of two ways, either the motor short circuits and stops working or the motor will develop high resistance and cause the IAC control motor to react slowly, either failure will cause the engine to stall at idle. When a trouble code scan is performed it sometimes won't always detect a failed or weak IAC motor. To check the IAC motor remove the unit, with the wires connected turn the key to the "on" position without starting the engine, the IAC should move in or out. If the IAC motor does nothing it has probably failed, replace it with a new unit and recheck system. note: while the IAC motor is removed clean (use aerosol carburetor cleaner) the passages the IAC uses to control idle air speed.

Ranger
03-30-09, 10:18 PM
If anything, yours would be the second type of failure (high resistance and slow reaction).

02CadiDevi
03-30-09, 10:22 PM
If anything, yours would be the second type of failure (high resistance and slow reaction).

absolutely my friend, I will check it and subsequently replace it if need be and post back with my results, thanks...

Ranger
03-30-09, 10:32 PM
I would suspect that the FSM would have a test procedure for it.

JB 1
04-30-09, 08:25 PM
Okay, I've been going through this intermitten stalling for a year and I spent hundreds of dollars on my 92 Deville 150K miles. I've taken it to 2 local Caddy dealerships and neither has pulled a code but both noticed the stalling still no relief. Things I've replaced CCM,EGR,02,MAP,DISTRIBUTOR, ROTOR,PLUGS&WIRES,FUEL FILTER, TB CLEANED, ENGINE SOAKED AT DEALERSHIP OVERNIGHT,REPLACED GROUND WIRE. IS THERE ANYONE THAT HAS A CLUE AS TO WHAT IS WRONG? Because I'm not spending anymore large amounts I'm just going accept what the salvage yard gives me and be done. I was looking at purchasing a 05 DTS but after reading all these stalling iussues I am scared to buy it.

Ranger
04-30-09, 09:19 PM
Okay, I've been going through this intermitten stalling for a year and I spent hundreds of dollars on my 92 Deville 150K miles. I've taken it to 2 local Caddy dealerships and neither has pulled a code but both noticed the stalling still no relief. Things I've replaced CCM,EGR,02,MAP,DISTRIBUTOR, ROTOR,PLUGS&WIRES,FUEL FILTER, TB CLEANED, ENGINE SOAKED AT DEALERSHIP OVERNIGHT,REPLACED GROUND WIRE. IS THERE ANYONE THAT HAS A CLUE AS TO WHAT IS WRONG? Because I'm not spending anymore large amounts I'm just going accept what the salvage yard gives me and be done. I was looking at purchasing a 05 DTS but after reading all these stalling iussues I am scared to buy it.

Start a new thread. Don't hijack this one. You have a different engine anyway.

02CadiDevi
05-01-09, 12:42 AM
just an update the IAC replacement was a complete success, also I was able to score the part at more then half off by going to a salvage yard I had used in the past to get the replacement. Thanks for the input and all the help she is error code free and running smooth....

Ranger
05-01-09, 11:00 AM
:thumbsup: Another satisfied costumer.

JB 1
05-01-09, 06:08 PM
Start a new thread. Don't hijack this one. You have a different engine anyway.

My bad I was at work while writing this did not mean to hijack.

JB 1
05-01-09, 06:12 PM
I'm aware that I have a different engine but the stalling issue seems to cover all engine models. So if you have any suggestion I would greatly appreciate it.

02CadiDevi
05-03-09, 08:21 PM
I'm aware that I have a different engine but the stalling issue seems to cover all engine models. So if you have any suggestion I would greatly appreciate it.

Ranger is great at figuring issues out... But he has a point starting a new thread will allow you to address your issue fresh, from what I have just learned the intake system to the northstar is a real piece of work... It has a number of different sensors and parts that could cause a stalling issue, also frorm research your issue could even be with crank sensors so the issue could be from a number of issues, start a new thread with tons of detail and see what happens, also pull codes if you dont get code like I didnt look to the IAC as it worked for me (thanks Ranger)...

nczek5ie
07-28-09, 02:53 PM
I was wondering if you have fixed the idling problem. I have just purchased a 2002 Eldorado with 22k miles. It has spent most of the time in the shop with the same issue. I found out that the previous owner eventually traded it in because of these issues, and cadillac service could not figure it out. After I cleaned the throttle body, the problem went away for a couple weeks. Now after being in the shop for the past week replacing a window motor, its stalling. Usually once without warning, after driving it cold for about 3-4min. And then it starts right back up again. No check engine, no codes. Let me know if you have any ideas from your own experience, I am scared to take it to a dealer and having them rip me off by trying 'this' and trying 'that'