: Fuel Pump went bad, & Balancer wobble?



benb870
03-18-09, 12:41 PM
anyone had a fuel pump start to go bad on them. I have a maggie and the magnavolt increases the voltage to the stock pump to increase fuel pressure.... I was running about 35 PSI and it should be around 60 PSI. I am having to replace the stock fuel pump. I may think about a boost-a-pump like the Aeromotive A1000. Anyone been in the same boat as me? :bigroll:

Also the balancer is not concentric and is out of round. I may need to replace in the future. It's good and tight on there, but there is a wobble.

any comments??? :)

PISNUOFF
03-18-09, 01:32 PM
Does the balancer leak? Mine wobbled so bad that it wore out the seal and leaked oil, or the seal was bad and made the balancer wobble and leak oil.

NormV
03-18-09, 01:53 PM
Brian, yours was removed once not by you?

Does the whole balancer or just the outer ring wobble? The balancer is two pieces separated by rubber.

Norm


Does the balancer leak? Mine wobbled so bad that it wore out the seal and leaked oil, or the seal was bad and made the balancer wobble and leak oil.

PISNUOFF
03-18-09, 01:58 PM
OK -- ......or when the balancer and seal were reinstalled the seal was damaged. However, there was a small leak before it was removed and reinstalled during the cam swap.

ctsv154
03-18-09, 03:21 PM
Does the balancer leak? Mine wobbled so bad that it wore out the seal and leaked oil, or the seal was bad and made the balancer wobble and leak oil.

This may not have been caused by a wobble. Some people dont let the crank pulleycenter the timing cover. You should leave the timing cover bolts loose, install the crank pulley, then tighten all the cover bolts. The bolt holes in the timing cover are bigger than the bolts so it will move around quite a bit. If the cover is bolted down before the pulley is installed this can put uneven pressure on the seal and cause a leak.

benb870
03-18-09, 04:29 PM
There is no leak. If there was a leak would i see it on the ground? If so then nothing. I was under the car and didnt see any residue on anything either.

so if no leak, then leave it alone and not replace? kinda like if it's not broke don't fix it???

CTSV_510
03-18-09, 06:07 PM
How many miles on your car and have you ever replaced your fuel filter?

nmaier2201
03-18-09, 06:28 PM
Ben: My balancer was also subject to a little wobble. The propeller heads on here told me it wasn't bad and to leave it. I was going to get an smaller UD pulley.... but I have had this wobble for about 6months and there is no leaking from the seal... so even though I'm feeling like I'm abusing my V... for now I'm leaving it. Here is a youtube vid of it so you can see how bad it's wobbling.... which isn't real bad at all.


OlfvlcyAchQ

Or here is the link

www.youtube.com/v/OlfvlcyAchQ

benb870
03-18-09, 07:20 PM
thanks Nmair, I did see that video on youtube. my is worse than yours.

ctsv 510 the car has 27K miles on it and i have not replaced the fuel filter. I am replacing it along with the pump and sending unit. i am not sure if a clogged filter would reduce PSI by almost 30?
thanks

ctsv154
03-18-09, 09:05 PM
I could but I dont see that being a problem at 27k unless you have been getting some really bad gas and or running the thing all the way to E before you fill up.

benb870
03-19-09, 10:52 AM
i try not to run it down to E, but it may be a batch of bad gas. I try to only use Sunoco 93. maybe a fule system flush / clean might help?