: Got my CTS-V and would like some advice



aceofblitz
03-16-09, 11:12 PM
Hey guys,

Two days ago, I asked my dealership to send my CTS-V to a shop next door for paint protection and tinting while I finish all the paperwork and registration (Tried getting the plate number 75932 for obvious reasons but failed :helpless:). So after finishing off everything, I went to the shop and tried turning the engine on - battery was discharged probably because the inside lights were on while they were applying the tint with the doors open. So they jump started the car (don't ask about the procedure I was away while they charged it) and realized as soon as I left that there was a CEL all lit up. It did freak me out at first but it disappeared the next day.

Due to that incident happening to me I am feeling a little bit paranoid... because everything is okay but the cruise control now doesn't want to engage now (will see if it changes tomorrow).

So do you guys think I should wait it out? maybe the solution is simpler than it seems?

My opinion is that maybe I should take it to the dealership to check up on the battery, fuse box, and reflash the ECU. Your thoughts?

P.S It's White/Ebony and I will take pics of it as soon as I get my tripod back from my 300C SRT8 :bonkers:

OldDrummer55
03-17-09, 02:06 AM
If you can isolate exact features that are not working, take it back and tell them to fix it. Also refresh their memory about the jump, etc.

wait4me
03-17-09, 10:30 AM
The cruise control will not work with stored codes. You are going thru exactly what i did last week.

You need to go to your trunk. On the passenger side there is a flap. pull off the flap and then undu the positive battery post for a few minutes. No tools are required. the Lever just moves over and you can pull it up and then the clamp comes off. Then plug it back in..

IF that dont work, then you need to go to the dealer and have them manual clear all 22 modules....

Razorecko
03-17-09, 11:32 AM
^ lol, that sounds like a real pain in the arse.

thebigjimsho
03-17-09, 02:14 PM
Ah well. At least it's nothing new...

aceofblitz
03-17-09, 03:08 PM
Wait4me I tried out the battery trick as you suggested, cruise control started working again! But after I turned the car off to run some errands, it went back to the same issue when I came back. Tried the battery trick again but it didn't work this time. I guess I'm going to send it to the dealership to check out. Thanks for your suggestions