: EBCM or EBTCM went bad ...



lawrence1
03-13-09, 04:45 AM
basically my abs and t/c lights are on(and the systems are not working) due to a failed EBCM or EBTCM or whatever it's called. I always thaught this module was called the ABS control module but i guess Cadillac/GM has a different name for this part.

either way i need a new one and it's apparent from my cross referencing that this module is the same for all CTS cars w/ sport suspension and/or active brake control and all SRX cars.

the module has the following part # 89060339

does anyone have a car they're parting out with a good WORKING abs module? if so and you'd like to sell it i am interested in taking it off your hands.

thanks again.

NormV
03-14-09, 03:03 PM
Where is it located? I have a ABS distribution block with the computer attached. It has two number starting with 2575xxxx. It's from a 05 V.

Thanks,

Norm

lawrence1
03-15-09, 03:04 PM
how's it going Norm ... the piece of sh** is located in the front of the car right behind the radiator. it's mounted in the center of the front subframe. it's part of the abs distribution block ...

i'm still trying to figure out if it's bad or not at this point because i messed with the wire harness that attaches to it and it seemed to be loose. also the clamp that is supposed to secure it to the module seems to not lock the wiring to the module properly as you can just pull the plug out without unlocking the tab. either way i plugged it back in and now the brake lights work fine(they've been working for 2 days now).

i'm having the codes pulled tomorow and the module looked at by a GM tech. if it's bad then i'm probably going to need one. my ABS an T/C lights have been ON as well for a while now and i'm thinking everything might be related. i'll know more tommorow.

NormV
03-15-09, 05:13 PM
Zip ties work great compared to a new harness! :)


Norm

wait4me
05-11-09, 12:07 PM
You just have a BAD GROUND.

There is a pinched wire that finally cut thru itself.

The pinched wire is on the front fuse box in between it and the front bumper. Look down on the right of the box / front corner and you will see a small diameter wire under the boxes corner. If you move the wire around you will get your lights back. I have seen 4 cars with this identical issue. They have the wiring to tight so it gets stuck into that corner and just slowly starts cutting itself. The fix is to cut it right there, and then run the wiring over to the strut tower bolt and ground it with the big one where the hood strut is. Then problem solved.

lawrence1
05-12-09, 02:00 PM
thanks for your help. i wish i would've known this sooner. i sold the car about 3 weeks ago and will probably be moving into an M5 soon. the V is a fun car but my warranty ran out and with only 16k miles(2005 MY) i had quite a few issues that made me doubt the car(rear end whine, bad driveshaft flex disc, ebtcm,, yaw sensor, 2 abs sensors, cd changer went bad, drive belt tensioner, p/s pump went bad ...

great forum and i appreciate you taking the time to answer my question.

NormV
05-12-09, 02:32 PM
You could have gotten an extended warranty. Probably would have less than the maintenance on an E39. Friend had one fun to drive but eventually bought a A6 2.7TT chipped and hot rid of the Disco.

Sad to see you go! Maybe be back for an 09 down the road?! :)


Norm


thanks for your help. i wish i would've known this sooner. i sold the car about 3 weeks ago and will probably be moving into an M5 soon. the V is a fun car but my warranty ran out and with only 16k miles(2005 MY) i had quite a few issues that made me doubt the car(rear end whine, bad driveshaft flex disc, ebtcm,, yaw sensor, 2 abs sensors, cd changer went bad, drive belt tensioner, p/s pump went bad ...

great forum and i appreciate you taking the time to answer my question.

johnys customs
04-18-12, 09:46 PM
bump old thread....

do you get codes when the module is bad? whats the syptoms?

darkman
04-18-12, 09:57 PM
http://www.cadillacforums.com/forums/2004-2007-cadillac-cts-v-general/252328-just-bought-my-first-v-having.html

http://www.cadillacforums.com/forums/2004-2007-cadillac-cts-v-general/252328-just-bought-my-first-v-having.html

Noriega7
04-18-12, 11:24 PM
Having the same problem. Def gonna check out the wires before dropping the 500 bucks