: Please help! Lowering V/Stability Control Service, TC off, ABS off



Daniel35489
03-11-09, 08:19 PM
First let me say thank you to all the forum members here who have helped me greatly by posting such great info!I have an issue and need some desperate assistance. (I have searched prior to posting this also) I have installed the front springs (eibach pro kit) and was too tired or lazy to do the rears so I had a local meineke install the rears using the spacers I got from Nels. When I picked up my car I have a message that comes on saying "service stability system." abs and t/c lights are lit. What went wrong here? Is this normal? I'm sure they obviously installed something wrong but i can't seem to figure out what would have that effect? Thanks in advance for your help.

darkman
03-11-09, 08:47 PM
The information is accessed by DTC (diganostic troubler code). Many auto parts stores, such as AutoZone will attach a scantool and tell you the DTCs that have set.

whisler151
03-11-09, 08:52 PM
Hmmm...I'm no help. I had my performance shop put mine on, no problems at all.

I wish I could be more help.

Daniel35489
03-11-09, 09:02 PM
Would an improper install cause these codes to trip? I have contacted them and I will be bringing my car back to them with the printed off instructions from cadillacfaq.com showing them exactly how to do it. Of course this is probably my fault, I should have taken them with me instead of assuming a professionally licensed shop could do a simple install. The front desk guy was so arrogant and had no clue what the V was. He was asking if I had the 24 valve V-6 and if I have single or dual exhaust! what the F@#! does that have to do with putting in the springs and spacers that I am supplying? I'm just frustrated...

whisler151
03-11-09, 09:14 PM
Would an improper install cause these codes to trip? I have contacted them and I will be bringing my car back to them with the printed off instructions from cadillacfaq.com showing them exactly how to do it. Of course this is probably my fault, I should have taken them with me instead of assuming a professionally licensed shop could do a simple install. The front desk guy was so arrogant and had no clue what the V was. He was asking if I had the 24 valve V-6 and if I have single or dual exhaust! what the F@#! does that have to do with putting in the springs and spacers that I am supplying? I'm just frustrated...

Good call...I had those same instructions printed off and in hand when I showed up at the shop. You cant go wrong when they have have step by step instructions.

CadzillaTN
03-11-09, 09:15 PM
Oh, man....this is fishy. Are you sure some jackoff didn't just "test drive" it and F something up? I wouldn't trust Mineike to change windshield wipers let alone springs.



The information is accessed by DTC (diganostic troubler code). Many auto parts stores, such as AutoZone will attach a scantool and tell you the DTCs that have set.

If you're cool they will usually reset them for you too. Sometimes this isn't a good idea depending on the severity of the possible problem (like this), but if you're changing an o2 sensor or something it really helps.

Twitch
03-11-09, 09:54 PM
Maybe they just unplugged a wheel speed sensor.

VforMe
03-11-09, 09:57 PM
Maybe they just unplugged a wheel speed sensor.

Or damaged it....but good call. I would bet that is your problem.

Daniel35489
03-12-09, 12:18 AM
I'm unfamiliar with a speed sensor. Where is it located? How can i check that it is operating properly? :banghead:

Daniel35489
03-12-09, 08:45 PM
well I took it to Ken Batchelor Cadillac here is San Antonio and the culprit was the speed sensor. Seems it was damaged by the geniuses at meineke during the spring installation. I'm not sure how thats possible but when i dropped it off it was fine, 1.5 hours later it was damaged. Thanks for all your help guys!