: Battery went dead! Radio no longer worked.



wait4me
03-09-09, 11:52 AM
Well guys, so you know.

My battery went dead on me last week after sitting for 2 days. When they go dead it causes some interesting issues.

I used the hidden key to open the door.
Then popped open the hood, and grabbed the battery charger.

Charged it at 4 amps, which is the lowest setting for about 10 minutes, then moved it up to 20. Then it charged the battery up and then i started the car about an hour later.

Well, It seems, that when the voltage drops below a threshold, 8volts in this case, All the modules in the car store a battery fault code and wont turn back on!

I had to use my tech 2 to clear every stinking module, there are 22 seperate modules that store the code.. Each module wanted to be reset... How annoying.

Well, after clearing out all the codes everything was back on, EXCEPT the radio and the HVAC face.

So at that time, i then had to go into the trunk and pull the 12v positive from the post and then put it back on and then everything went back to normal.

So, the modules must have to see 12v right away or they lock down. Crazy..


I did find the reason for the dead battery though. It seems the 4way round switch on my ricaro on the driver side sticks on the one side that deflates everything.. HMMM As soon as i unstuck it, the battery hasnt died since. Now to hope the dealer can fix the switch....

SSideways
03-09-09, 08:56 PM
nice to know.

where did you get the tech 2?

ewill3rd
03-10-09, 07:51 AM
Sometimes raising the voltage from low to high will cause logic lock issues on modules.
A battery disconnect might have yielded the same results in less time.
Not to say what you did was wrong, but Delco batteries like to be charged hard and fast, and logic tie ups are best reset with a battery disconnect. (in the future)
Glad you know what caused the battery to go down.

jwa999
03-30-09, 01:08 AM
My wife left the car in accessory overnight in the garage and the battery went completely dead.
The back doors where still open, i popped the hood and started charging first at 2 amps, didn't work, then at 4 amps for a few minutes, then at 6 amps, my changer's max. After a little while the interior of the car started waking up (it was still in accessory mode). The a/c control screens started flashing. I turned it to off, and after checking the remote was working again I closed the doors and let the battery charge. 10 hours later, it was full, I started the car and everything worked. No alerts, radio worked, nav worked. And strangely, the dashboard clock never missed a beat.

VirginiaGentleman
03-31-09, 10:23 PM
Sounds like the problem I had with an 02 Eldorado today. Battery had died, so I bought a new battery. Everything seems to work, except the radio. (Clock on the radio even works.) Unfortunately, the battery is under the hood in a very cramped spot.

Do you think if I disconnected the battery, and reconnected it, the radio may work again?