: Misfire Engine Code, Running Rough



Kuhns07
03-01-09, 02:22 PM
Having issues with a 1997 Catera. Started running rough out of the blue and I took it to Auto Zone and they said it's a engine misfire code. I checked all the plugs, and wires and made sure there was no oil build up around the spark plugs. Plugs and wires had previously been replaced in December as a tune up. I replaced the Crank posistion sensor, and no luck with any of it. I also got a spray bottle with soappy water to check for a vacume leak. The only other thing I'm thinking it could be is the coil pack.
Anyone have any advice of what to check next? It looks like to me the only way to change the coil pack is to pull the intake manifold??? Pain in the ass.
Please let me know if you have any suggestions.
Thanks

98 Catera
03-01-09, 03:18 PM
This problem & installation is posted on this forum a bunch of times. But the coil pack is dead, well atleast part of it. I bought my cartera and my coil pack went bad 2 weeks into owning it. I bought a new one from partstrain.com 297.00 + shipping. By a GM or BOSCH coil pack. You have to remove the wiper cal, wiper arms, wiper motor. That will give you room to get to it.

Mike

Army_MP_From_MO
03-01-09, 04:11 PM
Yep, sounds like a coil pack from what you described.

Kuhns07
03-01-09, 05:07 PM
That's what I'll do then
Thanks

gunther1000
03-03-09, 09:58 AM
I didn't have to remove the wipers, but it does make more room. It's a Bitch to get out of there but it is possible without removing the wiper cover. Mine was not coming off so I had to work around it.