: ABS and TC lights are ON. Service stability system message...



lawrence1
02-25-09, 11:45 PM
today i was waiting in line to get my SMOG check done, the car idled for about 10-15 mins before it went on the machine and all of a sudden, right before he was going to jump in to drive it up on the machine i hear a few beeps(windows were down).

i'm friends with the smog tech, and i was sitting right next to the car talking to him. i glance inside at the instrument cluster and there you have it .. TC and ABS lights are on and nav display says " service stability system". i'm thinking WTF ... nothing's plugged in to it yet and it wasn't on the dyno so no reason to have the lights come on.

it smogs fine and i leave hoping that the lights will turn off once i start driving. Nope ... all the way home the lights remained on and i even tried disconnecting the battery to reset them and as soon as i hook it back up and start the car they come on and stay on.


abs isnt working( i was able to lock up the brakes) and traction control isnnt working either. checked front speed/ abs sensors and they look fine. everything's plugged in properly.

another strange thing is that the G-Meter was showing 1.27 G to the right which is impossible, given that i never drive the car THAT hard.


any ideas? i know a tech 2 scanner would be great but i do not have access to one atm and i'd rather not go to the stealer(out of warranty).
car is stock except for a volant cai and cags delete.

Eldo1953
02-26-09, 01:14 PM
I would say excessive ohms at right front wheel speed sensor. I have had the exact same problem.

heavymetals
02-26-09, 01:35 PM
The Stabilitrack kept coming up "engaged" even when I was going straight and it would jerk the wheel.

Scary to say the least.

Turned out to be the yaw sensor.

I was showing 1.01 to the left.

Hope you find out whats wrong.

lawrence1
02-26-09, 09:38 PM
i reset the g meter today and it seemed to work fine but eventually it showed 1.07 g to the right again so i'm thinking the yaw sensor is toast at this point.

the lights are still on after driving the car for about 50 miles today.

for you guys that had this done under warranty ... whats the part number for the yaw sensor? how much is it? i'd like to get an idea before i throw it on the tech 2 to pull the codes.

814V
02-27-09, 03:23 AM
god bless the G meter

FactoryFast
02-27-09, 06:52 AM
you mean to tell me that stupid guage that tells me what a puss i am in the turns can also steer my car if it fails? Im pumped for that lawsuit.