: '96 STS Engine Stalling - Possible Electrical Problem?



Depthcharge
07-03-04, 06:42 AM
Hello,

My 96 STS w/120K has developed and intermittant engine stalling problem. It only happens when hot and when I come to a complete stop. Most of the time there is no problem at all.

Also, sometimes lately when I am decelerating but not quite stopped the radio to momentarily shut off then come on and my climate control system will turn off and stay off until I reset it.. The engine will does not die. I think all of the lights on the dash come on momentarily.

I am thinking this is an electrical problem. I have monitored the voltage and lost of the time it stays above 12.5V even at idle with heavy loads. But sometimes the voltage will drop lower and fluctuate around 10.5V or so. The engine seems to run rough then but the idle speed is still around 700.

I am wondering if one of the cooling fans may be drawing to much load? Expecially at startup? It does seem to matter if the A/C is on. I am not sure if this has ever happened when the A/C is off. Actually I shouldn't say A/C. I should say climate control because I know sometimes that the compressor is not running when I have the problem.

Also, sometimes when idling I get engine overtemp messages, idle engine, and speed limited to 90 MPH. The engine is not in fact overheated.

I used a CAR Code laptop based OBD-II scan tool to read the codes.
There were no standard codes set.
When I scanned the enanced codes this is what i got.

p1121 TP(TP)SCIHV
P1918 ND
U3F00 ND
P0091
P1918 ND
U3F00 ND
P119D ND
P1918 ND
U3F00 ND
P113A HO2STTRB1S2
P1918 ND
U3F00 ND
P1167 ND
P1599 ESONSD
P1918 ND
U3F00 ND
P1156 HO2SRMB2S1
P1918 ND
U3F00 ND
P1167 ND
P118C ND
P1599 ESONSD
P1610 SCPWD10BCN
P1904 ND
U3F00 ND
P0066 AIR INJ LO
P117B ND
P0730 GEAR RATIO
P0106 MAP RAN
P11A5 ND
P11C9 I3OC
P0062 HO2S HEAT 23
P11D2 I4OC
P0015 B CAM POS TP
P0156 O2S 22

A whole bunch of codes. All this stuff cannot be bad because 95% of the time the car runs great. I know what most of these codes are. I have a service manual.

My problem is with some many codes I don't know where to start.

Any ideas on where to start??

Tomorrow I will use the CCC to check the codes, clear them, and start over.

http://caddyinfo.ipbhost.com/style_images/1/addresscard.gif (javascript:PopUp('http://caddyinfo.ipbhost.com/index.php?act=Profile&CODE=showcard&MID=193','AddressCard','470','300','0','1','1','1' ))http://caddyinfo.ipbhost.com/style_images/1/p_pm.gif (http://caddyinfo.ipbhost.com/index.php?act=Msg&CODE=04&MID=193)http://caddyinfo.ipbhost.com/style_images/1/p_email.gif (http://caddyinfo.ipbhost.com/index.php?act=Mail&CODE=00&MID=193)

BeelzeBob
07-04-04, 12:05 AM
Certainly sounds like a bad connection somewhere.

Double and triple check the battery cables and connections at the battery. Even if the connections look good inspect the cables at the terminals at the battery. Look for puffy insulation indicating corrosion inside the cables. Check the ground connections at both ends.

Could also be a battery that has an intermittant cell that is going out.

With the low voltage and flickering lights it also could be a generator....

Hard to say exactly from what you've noticed.