: Weird electric problem?



Klei14
02-05-09, 12:29 AM
Happens alot when standing still, but also happens when I'm driving. All of the interior lights (dash, radio, climate, door switches) flicker on and off, and then go back to normal. I don't have to touch anything to make them do this, but they will just do it out of nowhere and stop. The car did have a bluetooth system that sucked, and was taken off, but no other aftermarket electronics that would cause this.

Any idea on what would cause this problem? My car is out of warranty, so I can't just bring it to the dealer to have them look at it.

Tom

Northern SRX
02-05-09, 05:52 AM
Why can't the dealer look at it? Sure, it'll cost you but, hey, this is their domain and all...

I'm suspecting battery or alternator. Anybody else?

n7don_srx
02-05-09, 09:25 AM
When you say "flicker on and off" do you mean completely off? Headlights do it too?

Not sure if Battery Voltage is one of the parameters available on the Driver Info Center display on your 06. It is on the 07. If so, you might monitor to check voltage when it happens.
Meantime make sure the battery cables are secure. In fact might disconnect at the battey, clean, optionally apply some diaelectric grease (available at most auto parts stores) and retighten.

Klei14
02-05-09, 01:01 PM
Why can't the dealer look at it? Sure, it'll cost you but, hey, this is their domain and all...

I'm suspecting battery or alternator. Anybody else?
The dealer would want 120$ just to look at the car, plus the cost of what ever it is to fix, no fun having a car out of warranty.


When you say "flicker on and off" do you mean completely off? Headlights do it too?

Not sure if Battery Voltage is one of the parameters available on the Driver Info Center display on your 06. It is on the 07. If so, you might monitor to check voltage when it happens.
Meantime make sure the battery cables are secure. In fact might disconnect at the battey, clean, optionally apply some diaelectric grease (available at most auto parts stores) and retighten.

Battery volt is fine, the battery was replaced like 6 months ago. The lights don't go on and of, they go dim then bright, and its only the interior lights.

I will clean the battery and check all the wires again this weekend, it should be in the 50's this weekend, so perfect to work on the car.

OakSRX04
02-06-09, 05:04 PM
My dome lights do the same thing. My 2004 still has the original battery as well. I checked the voltage reading on the DIC display and it varies from 14.2 to 14.9 V as the lights "pulse". After about a minute or so it stops and the reading maintains about 14.6 Volts. I don't think its a connection issue just the regulator doing its thing.

MuGeN
02-06-09, 07:43 PM
Check on driver seat side, under the carpet near the trim of the door theres a connector called splice pack for all the module communication. A lot of those connector are coroded and that do a lot of little problem like loosing radio, loosing left speaker,etc... At our dealer, we do A LOT of those connector. Theres a picture where the connector are located but is under the carpet. Remove the trim and look under the carpet. It will be easyer if you remove the seat. The connector is taped on the harness and he is white and green!

http://img.photobucket.com/albums/v372/MuGeN_teg/DriversSeat.jpg

MortnCyn
02-07-09, 09:21 AM
See this http://www.cadillacforums.com/forums/cadillac-srx-forum/160006-shut-off.html

bigdaddysrx
02-09-09, 09:29 AM
My '04 N* spent 10 days at the dealer late late year for the same problem. Many harnesses were replaced.
BD

treslados
02-12-09, 10:10 AM
So far the random "on-off" has only been in the radio pod section.. I think. I write think because I'm not sure if it actually is happening or not...

350winder
01-21-12, 12:21 PM
Dome light slider for me.

Paulie Walnuts
01-28-12, 01:40 PM
so once in a while my signal lights just stop working - completely dead - if I stop and restart the engine - they live again.......just one of those things I can easily tolerate after 193,000 miles.............

PJ1520
02-01-12, 03:11 PM
so once in a while my signal lights just stop working - completely dead - if I stop and restart the engine - they live again.......just one of those things I can easily tolerate after 193,000 miles.............

Paulie.......you need to update your info in the "Show Us Your SRX Mileage" thread. Worst case, I think you are in still second place!

PJ