: '94 Fleetwood Keyless Entry PWR Lock/Trunk Problems



Badass94Cad
01-26-09, 12:56 PM
My white Caddy has gone HAYWIRE!!! Normally, when you start the car, it locks the doors, and it locks the doors when you turn off the car. On occasion since I've owned the car, I would come out to find that my car doors unlocked. And very rarely, maybe 3-4 times ever, my trunk was popped open.

Since I moved into my new apartment last week, everything's been crazy. The doors will constantly lock and unlock in the parking lot. Click click click every few seconds, all the time draining my battery. And I keep waking up to find the trunk open in the morning.

My first fix was to disconnect the battery. I left it off for a day, reconnected it, and everything seemed fine. I even drove it to the airport parking lot and left it there for a week! When I got back, trunk was closed, doors locked, and everything appeared to be normal. Now that I'm back to my apartment, it's crazy again. I pulled the fuses for power locks and trunk release until I can get it figured out, but I can still hear some relay or something clicking in my dash constantly. sad.gif

Do you think this is a computer issue? Would a flash or something be able to fix it? IDK if there's some signal in the area messing with my car, or it's something internal or what. I had been meaning to ask before, but it was never this big of an issue, just intermittent before. I think something in the computer must control it, because there is one strange thing that I noticed - in this car, as I said, doors lock and unlock with ignition. However, the blue car, which is a month or 2 newer, would lock and unlock depending if the car was in drive or park (if I remember correctly).

The trunk is still popping open on its own, even though I pulled the TRK REL fuse! It won't open if I press the trunk release button, though, so this makes no sense.

IDK...Got any ideas? HELP!!!

Badass94Cad
01-26-09, 01:46 PM
Is there a way to disable the keyless entry? I don't even use it anyway.

thefleetwoodguy
01-26-09, 06:17 PM
under the third brake light, theres a black box, that is the transmitter
simply unplug that box and you should be good to go

if this ONLY happens in your parking lot at home, Im guessing theres some kind of radio wave interference, something may be "splashing" into the receivers frequency
have you notice your hair falling out too? LOL

Badass94Cad
01-27-09, 08:04 AM
under the third brake light, theres a black box, that is the transmitter
simply unplug that box and you should be good to go

if this ONLY happens in your parking lot at home, Im guessing theres some kind of radio wave interference, something may be "splashing" into the receivers frequency
have you notice your hair falling out too? LOL

A friend of mine told me about the RKR box by the third brake light, but I couldn't immediately find it last night. All I saw was a black cable going up through a big black grommet and up into the rear tray, which I assumed to be the wiring for the third brake light. Do you have any better description of what I should look for?

The unlocking has happened previously at random places, but this insanity has just started at my new apartment, so I'm thinking there must be some crazy waves interfering. :(

Thanks!

Badass94Cad
01-27-09, 09:13 AM
I looked under the 3rd brake light cover for the RKE box, but the only wires that come up through the grommet are for the 3rd brake light itself.

Anybody know where the RKE is???

Badass94Cad
01-27-09, 01:14 PM
Well, I'm told the RKE box is supposed to be to the front of the 3rd brake light under the cover, but when I did a search of the cavity :roflmao: I couldn't find anything. :tears:

Does anybody know exactly where the RKE box is located in a '94? I don't want to have to pull out the rear seat and back deck if I don't have to...

thefleetwoodguy
01-27-09, 02:34 PM
it is under the third brake light cover, it mounts to the package tray with clips, follow that fat black cable, you should see a black box, about 3"x3"
with about about 15 wires going into it, ,
pull up on that box it should unsnap, then unplug it,
also the doors lock when you move the shift lever out of park, via a solenoid mounted at the base of the steering column, you may have an issue with the wiring, after market alarms can mess things up too,
back to the transmitter, just follow that fat black cable!!

Badass94Cad
01-27-09, 04:03 PM
Something's strange...The fat black cable splits into 2 smaller wires - 1 for each of the 2 bulbs in the third brake light. I can't seem to find this damn box. I looked all throughout the trunk too.

BTW, the doors locked when the vehicle was put into park in my blue '94, but this white '94 always locked the doors as soon as the ignition was started, and likewise unlocked when the car was turned off, which I thought unusual. My key fob says Goodwrench - perhaps a GM replacement - rather than Cadillac, as my blue one has. This is so weird!

Badass94Cad
01-27-09, 04:05 PM
Link to Kevin's thread about locating the RKE box (http://www.cadillacforums.com/forums/rwd-19xx-1984-deville-fleetwood-1985/140505-wheres-rke-module-my-95-fwb-2.html)

thefleetwoodguy
01-27-09, 05:30 PM
the ign shouldnt control the door locks, sounds like you may have an after market system, where are you in Mass??, im in concord NH
Im sure i could find anf fix the issue in 10 minutes....
that being said lets check the sticker in the trunk, the one with the option codes, do you have code AUO, that will at least tell you if what your looking for is even there in the first place, Im guessing not

Badass94Cad
01-28-09, 08:18 AM
the ign shouldnt control the door locks, sounds like you may have an after market system, where are you in Mass??, im in concord NH
Im sure i could find anf fix the issue in 10 minutes....
that being said lets check the sticker in the trunk, the one with the option codes, do you have code AUO, that will at least tell you if what your looking for is even there in the first place, Im guessing not

Boy, all of that would help, wouldn't it! :thepan::bonkers: The problem is I replaced the trunk lid due to being rearended, and didn't save the sticker! :helpless: The remote I have (and never even use) for RKE is a Goodwrench remote. It doesn't say Cadillac like my other car, but it is GM - a replacement perhaps? I'm not sure if GM did aftermarket installations.

I've also looked throughout the trunk for this mystery box, and haven't located it in there either.

Thanks for all the help. Unfortunately, I'm not in Mass anymore. I live in NJ now. :shhh: Oh well! Hopefully after this snow and ice storm clears up, I can pull the rear seat and package tray to see what I can see...
Jeff

jayoldschool
01-28-09, 12:59 PM
The remote I have (and never even use) for RKE is a Goodwrench remote. It doesn't say Cadillac like my other car, but it is GM - a replacement perhaps? I'm not sure if GM did aftermarket installations

The mystery becomes a little clearer. You probably have a GM VSS system. I have one on my SS, in addition to the AU0 keyless option. It provides an alarm along with the keyless function.

DO your remotes look like this:
http://i17.ebayimg.com/02/i/01/0d/8c/d5_1.JPG

If yes, you have an aftermarket GM system. Look under the dash, up around the steering column for the brain.

Badass94Cad
01-28-09, 04:03 PM
The mystery becomes a little clearer. You probably have a GM VSS system. I have one on my SS, in addition to the AU0 keyless option. It provides an alarm along with the keyless function.

DO your remotes look like this:
http://i17.ebayimg.com/02/i/01/0d/8c/d5_1.JPG

If yes, you have an aftermarket GM system. Look under the dash, up around the steering column for the brain.

Actually, the remote doesn't look like that, but your information may be very valuable. I'll look there too. :)

My remote is actually rectangular, with 2 buttons - lock and unlock. I tried to find a picture online, but all I could find was the one that looked like yours.

Thanks!
Jeff

Aron9000
01-29-09, 01:44 AM
I've driven a couple of 93-96 Fleetwoods, all the remotes looked like this one
http://ecx.images-amazon.com/images/I/51WGR3ZEH4L._SL500_AA250_.gif

Badass94Cad
01-29-09, 08:33 AM
I've driven a couple of 93-96 Fleetwoods, all the remotes looked like this one
http://ecx.images-amazon.com/images/I/51WGR3ZEH4L._SL500_AA250_.gif

Yeah, that's the factory one. I have that remote for my blue '94. :thumbsup:

Badass94Cad
02-02-09, 08:48 AM
I found the culprit! It was a GoodWrench keyless entry box, located under the dash. :uh: Unplugged it, no more lock gremlins!

jayoldschool
02-02-09, 09:31 AM
Glad to help!

Badass94Cad
02-03-09, 10:47 AM
Glad to help!

Thanks! :worship:

I'm not going to bother to fix it. I never used the keyless entry anyway because the remote was old and beat up. I had intended to get a new remote, but I just unplugged the system and everything seems good now. :cool2: