: So i got a new fuel pump/filter on 02 escalade



superdips
12-18-08, 06:01 PM
Just got a new fuel pump and filter installed and now im getting 2 codes that keep poping up:
P0171 and P0174
I did some research and found out they mean system too lean bank 1 and 2, not sure what that means. Has anyone here have any probelms with these codes, if so please let me know what you guys did to fix the problem, thanks.
My truck is a 2002 escalade AWD.

1class
12-20-08, 10:23 AM
PO171 and PO174 lean codes are common on my other vehicle, Expedition.

There are many things that cause lean codes, too much air and not enough fuel.

Here are some points that may help guide you.

1. Not enough fuel, from weak pump or dirty fuel filter ( you took care of that with new pump )

2. Dirty mass airflow MAF sensor.

3. Vacuum leaks. (caused by many things, exhaust gas to egr valve, bad sensors.

4. Fuel pressure regulator or dirty fuel injectors.

Let us know what you come up with. Btw how many miles on your ride?

luxurylife33
12-20-08, 11:56 AM
i would check all your vacuum lines and double check the parts you got, make sure they were for the right car.

superdips
12-20-08, 02:27 PM
PO171 and PO174 lean codes are common on my other vehicle, Expedition.

There are many things that cause lean codes, too much air and not enough fuel.

Here are some points that may help guide you.

1. Not enough fuel, from weak pump or dirty fuel filter ( you took care of that with new pump )

2. Dirty mass airflow MAF sensor.

3. Vacuum leaks. (caused by many things, exhaust gas to egr valve, bad sensors.

4. Fuel pressure regulator or dirty fuel injectors.

Let us know what you come up with. Btw how many miles on your ride?


i have over a 100,000 miles on the truck, i spoke to the dealership and they said it may be due to cold waether (-25f) so i will wait a few weeks and see what happenes but in the mean time i will try to do those things you mentioned. Thanks