: failed smog test again. the HC is still high @15MPH



31415926
12-11-08, 09:30 PM
I replaced spark plugs, FPR, oil, airfilter and ran about 20 minutes before the 2nd test but the results are same: high HC @ 15mph.
Any ideas?
Thanks!

http://i267.photobucket.com/albums/ii319/accent_2008/smogtests.gif

ewill3rd
12-12-08, 09:17 AM
You really need to run some fuel system tests.
Your fuel pressure could be too high or you could have a leaking injector.
I have seen a few of both.

31415926
12-12-08, 01:04 PM
You really need to run some fuel system tests.
Your fuel pressure could be too high or you could have a leaking injector.
I have seen a few of both.
If it's a fuel pressure thing, could you tell me why it passed HC@ 25mph?

Submariner409
12-12-08, 02:51 PM
The slightly increased (engine) speed results in higher combustion chamber temperatures and thus lowers HC. Start looking at fuel pressure and injector leaks. High HC is analogous to a stuck choke in a carbureted engine. (You'll notice that one more digit in your 25 mph HC and it would also have failed. You're running rich.)

ewill3rd
12-12-08, 09:43 PM
sub is right, the higher engine load will use up more HC, the throttle plate is open more so you have more O2 for combustion.
At any rate, it is a place to start.

Ranger
12-13-08, 02:06 PM
The slightly increased (engine) speed results in higher combustion chamber temperatures and thus lowers HC. Start looking at fuel pressure and injector leaks. High HC is analogous to a stuck choke in a carbureted engine. (You'll notice that one more digit in your 25 mph HC and it would also have failed. You're running rich.)
Leaky FPR?

ewill3rd
12-14-08, 07:47 AM
He looked for that in another thread I am pretty sure.