: 2005 Escalade ESV Platinum Questions:



obxdiver
12-07-08, 07:20 PM
Hi Everyone.
I just took delivery of a like new 05 Escalade ESV Platinum
It is so sweet, I don't want to get out of it.
I am a green noob here, as this is my first Escalade.
I have some questions for the experts here and hopefully someone can help. Here they are

1.) Rear DVD Audio:
When I put in a DVD in the rear DVD player, I would like to put the audio over the speakers, so that everyone in the vehicle can hear it.
If I put in the DVD (in the rear player) and start playing it, I have a new “source” called “RSA”. For the most part, all I hear is static with this source selected, but if I turn the volume up very high, I can hear the DVD playing, but the sound quality is horrible.
Should I be able to hear good audio over all of the speakers from the rear DVD player or is only designed for the wireless headphones?

2.) Ultrasonic Rear Parking Assist (URPA)
The owners manual speaks about the URPA display located inside the vehicle near the rear window. It has 3 color coded lights used to provide distance info to the driver. Can someone tell me where these lights are? I cant find them. I have the pushbutton on my dash.

3.) Heated cup holders
When I press the “heat” button on the driver side heated cupholder, the light only blinks on quickly then immediately goes off. Does this indicate a short or some other problem with that cupholder? The passenger side cupholder light come on and stays on.

4.) DVD playback on NAV screen
Is there anyway, via a hack, to enable DVD playback on the front LCD screen in the dash?


5.) Curb View Assist Mirrors in Reverse
I have enabled this feature via the “DIC”, and the mirrors tilt down too far for me. I have adjusted them to my liking while in REVERSE, but it does not save my positions.
The next time I go in reverse, the mirrors tilt down to the old position again.
How do I save the new position. The manual says it saves it when you leave REVERSE, but mine is not.

shore
12-07-08, 08:04 PM
On #2 the lights are on the passeneger side rearmost pillar.Back-up to something and just look in your rearview mirrow.You will see them.Plus they chime.If you look back there you will see them.I too had to look around.They only work in reverse and with the reverse parking assist button not lit(off).

obxdiver
12-08-08, 05:56 PM
I have an update on item #5 about the Curb View Mirror feature.
I seem to have gotten my positions to be saved by going from REVERSE to DRIVE.
At least that is the last thing I did. Now they go to my saved positions.
Before, I went from REVERSE to PARK and they did not store the new positions.
So if anyone has this question about this feature, make sure you go from REVERSE to DRIVE to save the new positions.
The manual only says that they are saved when you "leave" reverse.

obxdiver
12-08-08, 06:02 PM
I want to add another question

6.) Stabilitrak
I have gotten now 4 times in 2 days the DIC message "STABILITRAK SYS DISABLED" immediately after starting the vehicle before leaving "PARK"
The manual says to turn off the engine and re-start it, which that seems to clear the error.
Why would this message occur so often?

obxdiver
12-10-08, 05:31 AM
I sure would appreciate any of you Platinum owners out there trying to play a DVD in the rear system and see if you can get the audio through the speakers.
After you insert the DVD, you should have a new source to select
I get that, but no audio comes out of the speakers.

All I want is to hear the DVD playing in the rear system while I am driving w/o using the wireless headphones.

ylwjacket
12-12-08, 11:44 PM
I have an '04, so I am not sure if it is the same or not, but selecting that source enables audio over all the speakers. We'll sometimes put the volume on so I can listen to it while the kids watch. It seems we had that static problem at one time, but I can't remember what the fix was. I'll try to remember. But, the kids will often watch movies with all of the sound on so my wife and I can listen along on long rides.

obxdiver
12-13-08, 07:48 AM
I have an '04, so I am not sure if it is the same or not, but selecting that source enables audio over all the speakers. We'll sometimes put the volume on so I can listen to it while the kids watch. It seems we had that static problem at one time, but I can't remember what the fix was. I'll try to remember. But, the kids will often watch movies with all of the sound on so my wife and I can listen along on long rides.

Thanks for the reply jacket
This is exactly what I want to do. Listen to the audio while the rear seat passengers watch (and listen) to the video.
I sure would appreciate if you could remember how you got the static to go away and the audio to play instead.
If I turn the volume all the way up, I can barely hear the audio of the DVD player, but the static is so loud at that point its pointless.
My 05 Lade was missing the DVD remote, so I am wondering if there is a button on the missing remote that needs to be pressed.:hmm:
BTW, all of my wireless headphones work fine, if that is a clue.

ylwjacket
12-13-08, 10:55 AM
Sounds just like what we had happen, and it was something dumb. I will go poke around in there later and see if I can remember. We thought we would have to listen only with the headphones. I am thinking there was some button on the front of the DVD unit that we pushed, like the tv/dvd/aux button on your tv set. I am thinking that was set to tv, so bad tv audio is what was coming over the speakers? it's vague, but coming back. I'll see if I can check. In the meantime, you might try that.

obxdiver
12-14-08, 09:01 AM
I have solved the static problem when playing a DVD over the vehicle speakers.
I am so happy with myself.
I found out that the previous owner had installed an after market Ipod interface, that somehow plugged into the XM radio module behind the glove box.
This allowed full control of the ipod with the factory radio.
I found the paperwork for it in the glovebox.
I was previously unaware that this was installed in the car.
I found the cable for the ipod in the center console.
Since I don't have an Ipod, I decided to unhook it and plug the factory wire harness plug back into the XM module. This white box (shown below) was hooked up "in-series" to the factory wiring harness.
Yippy...Now the rear DVD audio powers through the vehicle speakers with NO STATIC. It rocks now. Great sound, with plenty of volume. I was testing it with "The Eagles - Hell Freezes Over" concert DVD. Man I am now so happy.
Evidently, this unit is not made for this vehicle. So out it comes.

http://ecx.images-amazon.com/images/I/41Z7dWAqS6L._SL500_AA280_.jpg

http://ecx.images-amazon.com/images/I/311csTd%2BSgL._SL500_AA280_.jpg

mbovinet
12-14-08, 11:37 AM
Sounds great. I'm glad you were able to resolve your static issues.

ylwjacket
12-14-08, 06:23 PM
glad you found. i wouldn't thought of that one.

obxdiver
12-15-08, 05:56 AM
UPDATE to DVD static issue
After doing more research on the ipod interface that was installed, I found that who ever installed it left out that smaller pig tail wire harness shown in the picture.
Come to find out, this "Neucleus Ipod Interface" unit WAS made for GM radios with Class II Data Bus Systems, like the 2003-2008 Escalade NAV systems.
http://ecx.images-amazon.com/images/I/311csTd%2BSgL._SL500_AA280_.jpg
Luckily, they left that extra pigtail in the truck's glovebox.
That pigtail has some type of circuit board under some heat shrink tubing on the large end. There was a warning tag on it that said:
"URGENT: Use this harness only with vehicles with Rear Seat Entertainment systems"
So, as per instructions on web site, I hooked that pigtail "in-series" to the rest of the connections back to the XM module.
And now.....It all works properly. DVD audio is correct and I borrowed a friend's Ipod, and that works too. Now the Ipod tag info is shown on the NAV screen and the steering wheel buttons or the NAV touch screen can control the Ipod.
The original installer never installed the thing properly and obviously never checked the rear DVD playback afterwards.
It is strange how something plugged into the XM radio will effect the rear DVD playback over the vehicle speakers.

Now I guess I have to buy an Ipod.:crybaby:


To go back to #4 in my original post.
Is there anyway, via a hack, to enable DVD playback on the front LCD screen in the dash?
A search provided little info. That tells me probably there is no way to do it.

fasteddyII
12-15-08, 05:48 PM
Newbie here with an 04 - My URPA does not light up or beep I have searched the forum high and low and still have not seen a post about a fuse for this. Does anyone know where it might be Thanks Eddy

obxdiver
12-15-08, 06:03 PM
Newbie here with an 04 - My URPA does not light up or beep I have searched the forum high and low and still have not seen a post about a fuse for this. Does anyone know where it might be Thanks Eddy

Make sure the light on your dash is NOT lit. If the light near the pushbutton is ON, it means the system is DISABLED.

Sorry I don't know where the fuse is.

fasteddyII
12-15-08, 06:15 PM
Make sure the light on your dash is NOT lit. If the light near the pushbutton is ON, it means the system is DISABLED.
I am an idiot its works great thanks!

china99
12-20-08, 11:34 PM
Glad you got the DVD issue fixed. I didn't know how to help you because mine worked just fine. Thankfully!

My heated/cooled cup holders caught on fire one day in a drive thru. I really need to go have it serviced. I'm thinking those things are hazardous LOL.

kycop
04-15-09, 04:06 PM
I sure would appreciate any of you Platinum owners out there trying to play a DVD in the rear system and see if you can get the audio through the speakers.
After you insert the DVD, you should have a new source to select
I get that, but no audio comes out of the speakers.

All I want is to hear the DVD playing in the rear system while I am driving w/o using the wireless headphones.


i played with htis yesterday, Press the button next to the nav Radio unit that has a disc picture on it,, Thats for dvd sound