: ICM weak spark, have questions



jerseyjer
11-30-08, 09:17 AM
Listed in deville thread but I think its a more northstar technical question. 97 deville. Hard starting when outside temp is low, rough idle till warm. No codes and starts and runs fine when warm. Thought fuel pressure but only 4 lbs below spec, so I thought PCM isn't using proper fuel map to pulse injectors long enough. I didn't want to start to throw money @ the car so brought it to the dealer. $200 to tell me weak spark and I need a new ignition control module "ICM" $1052 to replace (cough) car is worth $1700 so went to the junk yard and got one from a 99 eldorado, hooked it up and started so now to wait till morning. Same trouble, glad I didn't waste the G. went and bought a spark tester for $11 and verified yes I still have a weak spark. Now the Q is what regulates spark amplitude, I know the coil packs amplifies the input but for all 4 to go bad, as with the plugs and wires (about 5 years old). Attached ground from batt to ICM bottom plate and looked for good spark, NO, attached 12V from batt to pink wire (power to the ICM) at ICM, still weak spark. Is it only the ICM that controls amplitude or does the PCM also control spark somehow? coolant temp sensor working as with the ambient sensor. I'm stuck and the wife wants her car back. Am I buying a new ICM or PCM? does the PCM need the dealer to flash it if I buy a refurbished one? I have gained a wealth of knowledge over the past couple days and thank anyone for replies.

Submariner409
11-30-08, 11:18 AM
Check your plug wiring against these diagrams......

Read the stickys at the top of the main pages in Northstar Performance, Technical Tips, Dnd deville and learn to pull and interpret your diagnostic codes.......it's all built into the car.....you don't need an aftermarket scanner.

97EldoCoupe
12-07-08, 06:52 AM
Sub is right- check your plug wire routing. I forget which ones but you can have two crossed and it will still run and misfire by very little. I had a rough starting problem on my '97 Eldo for a while, tested fuel pressure, changed the fuel filter, checked the FPR, new plugs, wires, and still hard to start some days. All of a sudden it started misfiring. Changed all four coils, starts every time first turn of the key. More power too. A failing coil can do funny things but still run on all 8 for a while. They're not that expensive - www.rockauto.com and it's not a bad idea for any 10+ year old N*.

stoveguyy
12-07-08, 10:11 PM
the dealer says weak spark. you say its not due to the ICM. so what would the conversation go like when the dealer charges you $1k to replace the ICM and it still does not run right? do you think they would replace the PCM or coils and credit you back the money for the ICM? i thought dealer techs were supposed to be qualified?

ewill3rd
12-07-08, 10:19 PM
The ICM doesn't control the power of the coil, only the timing under which it is fired.
The coil itself is in charge of the potency of the spark, that and the plug wires and gap.
If the resistance of the wires is off or the gap is not correct then it can affect spark.
The only way to test the "potency" of the spark is using an ST 125 spark tester.
If it jumps that, you are fine. I doubt that spark is your problem to be honest.

stove, some of us are.

jerseyjer
01-02-09, 09:03 AM
thanks for all your input, with a $4 spark tester it had a tough time jumping the big gap @ the end of the plug wire but when I went right to the coil it jumped it without a problem so on I went for new plugs and wires with the old icm. Fixed everything, for a week, and now not as bad but getting hard starting again. oh yea, the old plugs were a little dark so I think I'm fouling the plugs again, still no engine light. Pulled out the ol VOM and found 8 ohms to the engine and 24 ohms to the body from the batt. removed and cleaned connections and now 0 ohms to both. (did this when I did the plugs). now confused again as to why all the plugs were dark, why it only happens when freezing out, why did my PCM fuse blew, and why the dealer charged me for misdiagnosing. oh yea, always run super but switched to the big names now, ran fuel injector cleaner and drove 200 miles on the hwy to clean it all out.
WHY?

Ranger
01-02-09, 06:27 PM
the old plugs were a little dark so I think I'm fouling the plugs again
Have you checked for a leaky FPR?