: '03 SLS - "Surges" at slowdown and stoplights



dgroth
11-21-08, 11:47 PM
I have a problem with my '03 Cadillac SLS. It "surges". It will run ok at 25+ mph, but on slowdown and stoplights it "surges". I have tried looking for vacuum leaks, all hoses in good shape - It reports a code of P0300. I change oil regularly and generally take good care of the care. It has 100K+ miles on it currently and I would expect it should go for more. I have also cleaned the throttle body and tried de-gunking the upper part of the engine.

One note...if I unplug the MAF sensor, it runs great. So I thought - hmm - bad MAF sensor. Tried replacing it....nope. Same problem with the new sensor. Any other ideas? I'm at my wits end and my wife refuses to ride in the car until I get this fixed :)

MYUSA68
11-21-08, 11:50 PM
My 96 seville did that, was the IAC valve. Check that out.:thumbsup:

Ranger
11-21-08, 11:53 PM
Check the "plenum". It is the rubber coupler between the TB and the manifold. They tend to develop a crack on the underside where it can't be seen. Spray some Brakleen around it and listen for an RPM increase.

dgroth
11-22-08, 12:03 AM
I did that actually - nothing on the air plenum, but where the throttle body meets the intake manifold - there was an increase in RPM when I sprayed there...

dgroth
11-22-08, 12:04 AM
I just re-read my post - DUH - is there a rubber piece between the two? It looks like metal-to-metal with a flat gasket between them.

Ranger
11-22-08, 12:26 AM
is there a rubber piece between the two?
Yes, the 2000+ added the plenum. It is a common leak point. They tend to crack and leak.

Submariner409
11-22-08, 04:59 AM
Sounds like the plenum to me also.....Remove the painted engine cover and look down in the valley where the throttlebody casting joins the plastic intake manifold. There will be a single rubber bellows-type connector, secured with a bolted plate at the TB end and a s/s clamp on the intake manifold. Spray a shot of starter fluid or brake cleaner under there.......you'll hear a distinct engine speed change if that's your problem.

Many, many posts on the replacement procedure......basically, the intake manifold gets tilted and lifted off after removing the injectors and fuel rail. Good time to clean the inside of the TB (TB cleaner ONLY), replace the plenum, clean everything, oil the injector O-rings, and replace the fuel rail. 2 hours.

Plenum is $40 +/-, dealer only, intake gaskets at any large parts house. Manifold bolts torque to 8 ft/lb in a crosswise sequence starting from the center two bolts in 3 passes.

dgroth
11-23-08, 12:47 PM
Ok - I just did the test - removed the beauty cover, sprayed brakkleen on the underside of the plenum gasket while the engine was running (after a good warmup, of course) and viola - it had an increase in idle speed.

I called around and the plenum gasket is $26.31+tax and the intake gaskets about $14.00

dgroth
11-24-08, 02:42 AM
Thanks everyone - it was the torn gasket as you suggested. Car runs great, now!

Ranger
11-24-08, 11:13 AM
Glad you got it fixed. I suppose I should be expecting mine to go soon. Hope it goes before the warranty expires next year.