: 1994 Fleetwood Brougham transmission issues



94fwb
11-20-08, 04:18 PM
Hello All,

Once again I come to the GURU forum for some advice, I have been using this site since my first caddy and I always get the help I need! Here's todays question:

I have not had any issues with transmission until yesterday. No slipping, hesitation, nothing. It is a 1994 cadillac FWB with the 5.7l in it.

Transmission fluid is at proper level. I have not flushed it or serviced it since I bought it. It has 160k miles. I bought it at 144k.

I put it into gear (OD) and I can put the gas to the floor and it has higher RPMS but doesn't accelerate quickly as it usually does. It usually rockets up to hwy speeds. after about 30MPH it operates like normal? sometimes feels like it didn't engage into (OD) even though it is in (OD) gear. It is now clunking when put into reverse and occasionally at driving speeds. When I put it in park and turn off the key it lunges a tad? Any advice would be helpful. I am praying to the cadillac gods that it is something simple like a filter cleaning or a stuck throttle lever in the tranny. Any advice would be very helpful!

cadillac_al
11-20-08, 05:34 PM
No advice but you probably should change the trans filter and fluid. It may have never been done ever.

pompste
11-20-08, 11:03 PM
What color is the transmission fluid?

96Fleetwood
11-20-08, 11:50 PM
Torque Converter?

Pump issues?

Could be several different items. Do you have a check engine light?

I hate to say it, but my '96 used to clunk into reverse before the tranny died.

94fwb
11-22-08, 08:38 PM
I got a transmission flush as the fluid wasn't nice and red. I entered the Code Mode on the heater and It came up with a PCM code 84 I believe. Transmission Shift soleniod 3-2 problem. I am going to take it in to the dealer next week and have them test the solenoid with the machine to see if it is functioning. I don't think the tranny is going out. I can manual shift 1,2,d, with no hesitation problems. when I have it in OD it is sluggish on the acceleration. when it gets past 25 MPH she's her old rockety self. If I manual shift from 2,d, and then overdrive I have no issues. sometimes I can start the car in OD and take off and it doesn't do it until I pull to a stop light and then take off and she is sluggish till about 25mph. again. I'll fill ya'll in with more info next week and maybe it'll help someone in the future with a similar issue, if not it's new tranny time!

carguy911
11-27-08, 10:15 AM
First off let me say I just bought a '90 brougham with the 5.7L and i love it. Also love this site, more info than i can process in a week here. Anyway, as for your trans issues, if there is a shift solenoid sticking or malfunctioning, especially if it is 2-3 or 1-2 it would cause the problems you are encountering. If the shift solenoid does not work properly it could cause the trans to start out in a numerically higher gear than desired for proper acceleration. Having the solenoid replaced now should solve the problem without there being to much trans damage. Just my 2 cents, hope it helps.

94fwb
12-01-08, 04:23 PM
Here's the latest. My PCM code comes up 84, transmission 3-2 shift solenoid malfunction. I can clear the code by pressing off and it doesn't have the issue, until the solenoid sends a code to the PCM again. Usually at slow down or stop speeds. I bought a 3-2 shift solenoid and intend to replace it in a day or so and just wanted to know if anyone knew of where it's location, color, or wires are so that I can take the guess work out of it all.

Thanks