: Losing power?



myndrite
10-20-08, 08:37 PM
Hi guys,

I have an 05 cts v and just had my oil changed about a week ago. For some reason when I floor the gas pedal, it feels like I lost 40% of the car's power. It's just not pulling as it used to. I hear the engine screaming but I feel like I'm in my old civic! :confused: Any ideas?

whisler151
10-20-08, 08:42 PM
More mods

myndrite
10-20-08, 08:44 PM
More mods

:lies:

Jayrcr3
10-20-08, 08:52 PM
Your just getting used to it. Just go find a mustang and see, or add a maggie!!!!!!!

CadzillaTN
10-20-08, 09:05 PM
Your just getting used to it. Just go find a mustang and see, or add a maggie!!!!!!!

true,true,...or just spend some time away.

I just spent a week without my V...drove the woman's maxima on a trip. night and day. half the trip was twisty roads too...damnit!!!!!!!!!!
why didnt I drive the V? ground clearance. We went somewhat off-road. :alchi:

CTSV_510
10-20-08, 11:20 PM
Hi guys,

I have an 05 cts v and just had my oil changed about a week ago. For some reason when I floor the gas pedal, it feels like I lost 40% of the car's power. It's just not pulling as it used to. I hear the engine screaming but I feel like I'm in my old civic! :confused: Any ideas?

Like the other guys said, there's a point where the stock V just starts to feel slow. I remember - it's the point where you're pedal is on the floor but you feel like you're waiting forever to get to the next gear.

Cure = more mods.

I assume you have no check engine light? With the temperatures getting cooler (at least where I live), your car should feel faster and crisper on the throttle. My first recommendation would be to check your spark plugs.

homer403
10-21-08, 12:07 AM
I was experiencing excessive back lash from my diff... it got replace... and I feel I got full power back. Something to consider.