: Navigation Issues



2003RC51
10-18-08, 06:55 PM
I just had my 4th Navigation/Radio replaced under warranty and I am having a couple issues. #1 - It is programmed for Michigan(GM). #2 - When I go to the GPS info screen where it shows the satellites it says "out of range" and none of the satellites are green.

Every other Unit that was replaced worked fine. Anyone have any ideas?

On the main screen it tracks me but show me in Michigan in the middle of nowhere. And apparently its 1250+ miles to get home(dallas).

Any help would be great. Thanks.

SoSueMe
10-18-08, 07:04 PM
I am having the same issues... i just had my nav replaced under warranty after constantly getting "Disc Error" whenever i tried to use the Nav, and now after having the unit replaced the car thinks its in california... they keep telling me to bring it back, but i havent had the time yet... in the meantime i have become real familiar with california... all joking aside, my GPS info also reads "Out of Range..." so i would definitely benefit from any information anyone might have as to how to fix this annoying problem... thanks in advance!

Ak Jim
10-18-08, 07:10 PM
Dudes, checkout the sticky at the top of the page.

2003RC51
10-18-08, 07:25 PM
Dudes, checkout the sticky at the top of the page.

I read it but if this is something the dealership can take care of I would prefer to go that route since they are about 5 min away from me and it will be free(well $2 worth of gas).

Ak Jim
10-18-08, 09:56 PM
There are a bunch of posts to look thru but basically you can take it to the dealer for a firmware update. Some people have had such bad luck with dealers they would rather do it them selves.

heavymetals
10-18-08, 10:58 PM
Sounds like the GPS antenna isn't working.

2003RC51
10-19-08, 01:24 AM
That's kinda what I was thinking but it still tracks the car on the main screen. Its just in the wrong state. Will it still track the car if the GPS antenna isn't working?



Sounds like the GPS antenna isn't working.