: Hesitation when a/c is on?



feef706
06-18-04, 04:04 PM
I have a 96 Deville with 78k miles and lately it has had a slight hesitation between 40 and 50 miles an hour without the a/c on. And now I realize it is much worse with the a/c on. If Im sitting at a stop light with the air on I can feel the car hesitate sorta like a misfire, but not as dramatic. The rpms, also jump around from 600-700 at idle, more than usual, i would say it has irradic idle. I had an o2 sensor code a while back but now it is not giving me any check engine light or error code. Any help would be great. Thanks James

Donuts Kill
06-20-04, 06:31 AM
Does it seem like it "boggs" alittle between those speeds. I get aboggish feeling between those speeds on if i just lightly step on the gas. If i jumpon it it goes normally. im curious about the problem too.

marti4337
08-15-04, 12:56 PM
I have a 95 STS that has a similar problem, only way to " feel it " appearently is if you drive it daily,because I have had other people drive it to see if they feel it (I feel It @ tha gas pedal ) and they do not. I'm also curious !!!

mcowden
08-15-04, 02:27 PM
As the A/C compressor cycles on and off, the idle will change a little bit. The compressor puts a significant load on the engine, and to make up for the added load, the PCM opens up the idle air control valve a little bit to bring up the idle speed. So there will be a little bit of a change, probably a slight sag and then a slight jump when it kicks on and a slight jump followed by a sag when it kicks off. This is perfectly normal for a computer-controlled idle. Older cars used to just drop RPMs when the compressor was on and then they'd go back to normal when it went off. What you're describing is normal for idle unless the jumps and sags are extreme or the PCM doesn't make up for the RPM differences.

As for cruising speed hesitation, the overdrive kicks in around 41 MPH on light acceleration and the speed goes up with the rate of acceleration. Perhaps the overdrive is kicking in too early and you're feeling the effects of the engine speed being too low to support the acceleration. Does it just feel like it has a lack of torque, or doesn't want to accelerate past that speed? So if you accelerate from a complete stop with the pedal at a constant position all the way up to 65 MPH, will it hesitate between 40 and 50, or is it only when you are cruising at those speeds that you notice it? When you got the check engine light and codes for an O2 sensor, did you fix anything to make it go away or did it just disappear on its own? Have you noticed your gas mileage go down, or does the exhaust gas smell slightly of gas when the car is at full temperature?