: 05 Radiator Replace



Beardog
10-06-08, 09:28 PM
About a week ago I discovered that my radiator was slowly leaking and today the dealer replaced it under warranty. As I was driving home I was watching my digital temp gauge and all seemed fine until I got stuck in traffic. Sitting at a red light my temp went up to 230 degrees! Once I get moving and get the air going through it will drop down to 212-217. I checked my fuses and they are fine. What else can I look for? I do not hear any fans kicking on. I would have turned around and went back to the dealer but they would have been closed by the time I got back there.

stuckey
10-06-08, 09:44 PM
About a week ago I discovered that my radiator was slowly leaking and today the dealer replaced it under warranty. As I was driving home I was watching my digital temp gauge and all seemed fine until I got stuck in traffic. Sitting at a red light my temp went up to 230 degrees! Once I get moving and get the air going through it will drop down to 212-217. I checked my fuses and they are fine. What else can I look for? I do not hear any fans kicking on. I would have turned around and went back to the dealer but they would have been closed by the time I got back there.

check your coolant levels:rolleyes:

CTSV_510
10-06-08, 09:47 PM
Check the electrical connections for the fans to make sure the dealer plugged them back in. There is one on both sides, one for each fan.

stuckey
10-06-08, 11:46 PM
Check the electrical connections for the fans to make sure the dealer plugged them back in. There is one on both sides, one for each fan.

that's probably a more sensible approach ;)

SoJersey05V
10-07-08, 10:39 AM
never had a Rad replaced.. but after driving for a while and stopped at a light, i've seen my temps get close the 225 but then go back down as well...

it's weird though because the anolog gauge never moves past the hlfway point....

did have check coolant level show up on the screen once but all was fine.....

Beardog
10-07-08, 12:12 PM
I brought the car into the dealer today. When the car is sitting at idle the temp is hitting 228. The radiator fans will not turn on unless I turn on the AC. Should at least one of the fans turn on before 228 deg. with the AC turned off? Does anyone know at what temps the fans are supposed to turn on? This is with an outside temperature of 70 degrees I would hate to see what would happen at 110.

CadzillaTN
10-08-08, 11:24 PM
Im beginning to smell coolant now here and there, especially after short spirited runs. Probably leaking and going out but if so, very slowly. It will be replaced at some point under warranty so I'll deal with it as long as I can if temps and fluid levels remain ok. I can bundle this with few other issues on next dealer trip

Naf
10-09-08, 04:12 AM
Ok they dont want you to know this but i know what is wrong with your RAD...

If you look under the car where the nossle from the rad is you will notice a SMALL leak, durin manufacturin they forgot to push those 3 pins down, sealin the rad completely. I ran to my dealer and looked at all the CTSs and found it a common issue. Your best move is to get the High Capaciy Rad from Luke. Trust me on that. My MAX temp sittin in 120+ ambient temp in traffic is 200F, my normal runnin temp is 194F.

Additionally put in an Oil Cooler..Do a search in this forum "Naf" Oil Cooler feedback... Made the biggest diffin quality of oil after runs...