: Haunted Radio, Any one else experience this?



ahuyghe
10-01-08, 06:34 PM
Hi all:
Just wondering if anyone has experienced any strange operations from their radio. I have a 07 STS4 with the full nav pkg. The other day on the way home from work, i was sitting at a light, the radio turned up, grooving to a song i haven't heard in a long time. Suddenly, the radio station moves from 92.1, (the station it was tuned to), to 92.3 for ~1 second. Enough time for me to look at the station readout on the Video screen, then proceeds to slowly climb to the next useable frequency, 94.3. Kind of like a slow seek. It was like someone was turning the knob. :eek: I didn't have my hands anywhere near the steering wheel controls at all either.
I'm thinking, Wow! that is strange, anyway i immediately tune it back to 92.1 and continue listening to the song. Now driving down the street approx. 1 minute later it does it again, Exactly the same. :hmm: Now i'm thinking someone near by has a remote control now and is playing a joke! So i tune it back again and doesn't happen again.
About two days later, i'm out picking up my son from a friends, and am again listening to music, Pretty loud, (i like my music). I haven't picked up my son yet, so i am alone in the car driving down the street, now the volume on the radio drops down to a very low but still audible level. I'm thinking, maybe theres a call coming in, but if that were the case, the radio mutes. so i wait for about 10 seconds to see if the volume returns. Nope. so i turn it back up myself. :rant2:

I have had a few other electronic things crop up with this car like a red warning pops up in the HUD ocassionally for a few seconds telling me to check my gauges. When i check them immediately when this happens, i can't see anything out of the ordinary.

Nobody (dealership or GM canada) seems to be able to tell me what the heck that means! :mad:

So i'm curious, :hmm: has anyone else had similar experiences with their Cadillac? and if so, did the problems ever get resolved and how?

Any help would be greatly appreciated.


Thank you

Al

2007 Cadillac STS 4
2003 Chevy Avalanche Z71
2002 Mustang
1996 Coachman Santara 32FL
2006 Suzuki Boulevarde M109R
2001 Honda GL1800 Goldwing

porkfarm
10-01-08, 06:55 PM
Yeah. same here. played old songs that I loved, then would switch over and play another. If you use the dial nob on the right to change the station, give it a few turns. That should clear it up. I think it gets stuck in between and will change stations on it's own. Have not had the problem since.

ahuyghe
10-02-08, 10:56 AM
This might help with the station change, but then what about the volume? Seems that there is too much happening there to suggest that the knobs need to be adjusted. I have never had this happen on any stereo, be it home or automotive. I believe there is something amiss in the complexity of this unit.

rb92gt
10-02-08, 11:55 AM
As far as station changing... as mentioned above, if R knob is in between positions weird stuf happens.

As far as volume... might have "audio pilot" on... it adjusts volume based on speed (and I believe noise level in car). Try turning it off and see if it helps.

ahuyghe
10-02-08, 12:43 PM
Thanks for the suggestion, but my 2003 avalanche Z71 has this auto volume feature (speed sensing volume control) and i am familiar with this, but in this case, the volume moved a LOT. From loud to fairly soft. No change in speed or anything else to set it off. Just a major volume drop for no reason. But thanks any way. Neither of these problems have happened since, so i'm just going to keep my eye on it.
As for the Check gauges warning in the HUD. I got it again on the way to work this morning. I couldn't detect any problem with the gauges. This is beginning to concern me.The dealership states that all they can do is test it. Based on my past experience with my dealership. I wouldn't let them get near the car with a cleaning rag! SERIOUSLY. The last time they had the car, i had to have the entire car professionally polished to remove the scratches from the clear coat because when the car went into the shop, it was dirty from the rain the day before, when they completed their work, the technician wet the car down with no soap and rubbed the grime all over the place. Being a black car, it looked OK wet. When i picked it up, It looked like someone hit it with a block of sandpaper. I was not a happy camper that day. I ended up taking pictures as evidence and the dealership ended up paying for the polishing by a third party, as i was not giving them the keys to the car again.

ahuyghe
10-03-08, 10:30 AM
Just getting back to the Auto Volume control, My 2007 Cadillac STS 4 with Nav pkg doesn't have that feature, or if it does, i can't seem to locate where to enable/Disable it.

hazcaddy
10-03-08, 02:47 PM
I had all sorts of radio problems on my previous DHS. Each time the radio got replaced by the dealer, as it was under warranty and easier to swap out rather than mess with it. I think I was on radio #4 by the time I got rid of the car - got to be a bit of a pain re-programming the pre-sets every time.

Your dealer shouldn't have to "test" it: demand that they replace it.

ahuyghe
10-03-08, 04:34 PM
Sorry, Guess i may have confused the issue a bit. The dealership was to test the warning in the HUD that keeps coming up in red lettering, "CHECK GAUGES". I haven't even mentioned the radio problem to them yet.

rb92gt
10-03-08, 06:13 PM
"Audio Pilot": Press musical note button between "SRCE" and "CONFIG", then press top left touch screen button "Audio Pilot" button.