: Always midnight



hugo
09-26-08, 03:17 PM
I have a 2008 STS with IntelliBeam that thinks it's always midnight. The DRL feature does not seem to be operating properly and the upper blue tinted headlight bulbs, the taillights and the side marker lights are always illuminated even in bright sunlight. I tried turning the lights on and off using the controls on the turn signal stalk and the above operating condition occurs when AUTOMATIC LIGHTS ON is displayed on the DIC. The IntelliBeam feature is turned on.

Before I waste half a day and two gallons of gas plus tolls going to the dealer, is there supposed to be a small dark gray translucent plastic dome over the Light Sensor located in the center of the dash near the windshield or is this a protective cover that should have been removed by the dealer? It appears to have two small protrusions on the sides at the bottom and I have tried to remove it but it does not want to come off and I donít want to force it in case it should be there.

bigwood
09-26-08, 04:27 PM
Check to make sure your wipers are not turned on.

ajmasala
09-26-08, 04:30 PM
Can you check to make sure your windshield wiper stalk is not set to auto.

If your windsheild wipers are set to auto then the main headlamps will always come on - regardless of whether it is raining or not.

HTH.

hugo
09-26-08, 07:37 PM
Thanks guys.

That was the solution. I hate cars that are smarter than I am and this one makes my brain hurt.

Now do you have a magic solution for the cruise control that only works about half the time?

pjbizjak
09-26-08, 07:45 PM
Cruise control.Check to see if it is turned on, if your one of those drivers that "ride" the brake pedal, just the slightest touch of the brake will turn off the cruise. Or make sure when you use the turn signal you're not accidentally turning off the cruise.

hugo
09-26-08, 09:13 PM
None of the above are causing the problem. When I try to set the speed, sometimes the green icon on the dash will come on and sometimes it won't. When it does come on it works fine.

justgreat
09-27-08, 08:20 AM
don't feel bad, i did the same thing with my 06 sts...even went back to the dealer....someone on this board showed me the light....oh god, bad pun....


jackg
06 sts6