: cdx error, dvd doesnt work, aux in works 'sometimes'



carguyshu
09-08-08, 11:17 PM
just got my navigation in (put an 05 dvd navi in an 00 sts) and the theftlock reprogrammed from the dealer. when i first got in the aux in would not work at all. when you press the dvd button it just kept saying 'no dvd' and thats it. after jiggling the harness that was made up for me it randomly does and does not work (the aux in that it).

the dvd will not work at all. i've tried several disc, some burned, most not non-burned originals and nothing. it won't do anything. the dvd part simply wont work.

when i put a cd in the head unit and click cd it just says 'cdx error' actually it says 'cdx error' every single time you push cd regardless if there is anything in there or not.


questions are: has any of these things happened to anyone else? what do i need to do to ensure that the jiggling doesnt keep cutting out my aux in? also, do you guys think it is wiring, the dealer messing up the program, or a messed up navi head unit? im stuck here. to collect all the things needed to put this thing together hasnt been cheap and thus far im pretty disappointed.

ryan

Cliff8928
09-09-08, 03:11 AM
Did you replace your CD changer?

carguyshu
09-09-08, 12:03 PM
not yet, but should that really affect the head unit not playing cd's or dvd's? I unplugged the old one.

Cliff8928
09-09-08, 02:27 PM
not yet, but should that really affect the head unit not playing cd's or dvd's? I unplugged the old one.

Not sure. Just that "CDX" means the changer. It may try to look for the changer before it even tries the internal slot. Does the navigation work?

The Nav came from a DeVille?

CadillacSTS42005
09-09-08, 05:10 PM
i assume you have one of my cables?
sounds alot like a dead unit to me ive had it happen before hence why i only deal with salvage yards they give a 30 day warranty at least

carguyshu
09-11-08, 01:11 AM
the one i got was from a salvage yard on ebay and yea it came with a warranty, so if all else fails i can probably get my money back.

yes, it is from an 05 deville.

yes, i have one of ur cables. the aux in randomly works and i can cause it to do so by just jiggling the cable, so i believe something is likely loose in the retro fit harness. any suggestions on where to look for a loose connection on it? does the aux cables just go straits to the pins, or are they tied to another cable in the harness?

i will have a nav disc hopefully in the next couple of days and will try that to see if it works.

CadillacSTS42005
09-12-08, 12:31 AM
sounds like a weak wire
send it back and ill check it out if you like

carguyshu
09-12-08, 01:52 AM
As soon as I get another nav unit from the salvage yard and make sure that one works fine I'll send it your way, unless for some reason you think that something in the cable could be affecting the cd/dvd drive, although I don't see how that could affect it.

CadillacSTS42005
09-12-08, 07:43 PM
no way possible a loose wire kills a hard drive

carguyshu
09-14-08, 04:46 PM
it's the CD/DVd drive that I can't get to work, not the hard drive.

smooth_caramel
10-10-08, 04:02 AM
Can you give me the ebay seller you bought it from?

carguyshu
10-10-08, 11:52 PM
lqonline i think is the name. i asked them 3 weeks ago if i could get a refund and they said yes, just send us ur address and we will get UPS to pick it back up. I replied asking if I could just get another one from them and haven't heard back since. I guess i'm gonna be forced to get a refund on that one and look for another. hopefully they still take it back....

CadillacSTS42005
10-11-08, 12:17 AM
goodluck
your beyond the 30 days to file with ebay

CJGirone
02-16-09, 07:15 PM
Had the same problem, everything appeared to work but the sound and when I would push the "CD" button we would get "CDX Error". To fix this problem, go to the passenger side, under the floor mat. There is a fuse box. On the 2004, it is fuse 27. Take it out and put it back in. Just make sure the volume is down!! For whatever reason, it reset and works fine now.

carguyshu
02-19-09, 01:22 AM
hmm... I will have to try that. Is the fuse behind the kick panel? I didn't know there were any fuses on the passenger side. The sound still works (the radio) it's just that the DVD drive doesn't work at all. When I put in a nav disc, DVD video, CD, anything, the drive just doesn't work. Did this happen to you also?

After saying they would refund the purchase, they backed out and then said they wouldn't. I'm pretty unhappy about the situation.

cadillacnick99sls
03-04-09, 12:09 AM
hmm... I will have to try that. Is the fuse behind the kick panel? I didn't know there were any fuses on the passenger side. The sound still works (the radio) it's just that the DVD drive doesn't work at all. When I put in a nav disc, DVD video, CD, anything, the drive just doesn't work. Did this happen to you also?

After saying they would refund the purchase, they backed out and then said they wouldn't. I'm pretty unhappy about the situation.

Good ole crooks. just makes you want to pour gasoline under there door and lite a match. Know how you feel everyones been jerked :devil: