: Bluetooth Use 07 STS



Refdog
08-07-08, 12:14 PM
I have had my 07 STS for about a month. It has the navigation system. When I am using my phone in Bluetooth mode I have a problem. If I dial out the radio mutes and I can hear on the Bluetooth.
However, if I receive an incoming call through my Bluetooth, the radio mutes when it rings, but as soon as I press the button to answer the phone the radio comes back on and it then can't be adjusted or muted manually. So, I can't hear anything over the Bluetooth.
I'm thinking that I have something set up wrong.
Any ideas?
Thanks.

Buzz48317
08-07-08, 03:01 PM
What kind of phone are you using? I had this problem intermittenly before I changed handsets. With the new phone it hardly happens at all (maybe once in the past 6 months or so).

Refdog
08-08-08, 08:01 AM
My phone is a Palm Treo 700 with Verizon as the service carrier. Works great except for the problem above. Plus I need that phone for all the other features so changing isn't an option.

jono6406
08-08-08, 12:22 PM
I have a Razr and it pairs very well with my STS. I get no feedback and it connects everytime I get into my car without incident.I don't know why but ever since I inserted my navi disc my bluetooth is working perfectly.

Jono

Maximln
08-08-08, 11:30 PM
No, you are not doing anything wrong. This is a very common problem with the bluetooth system. Some of the members have reported good luck with the navigation update from the dealer but it has done nothing for me. I also have the Treo 700 from Verizon and I have the same problem. I think different phones work better than others.

Max

Buzz48317
08-09-08, 03:22 PM
I had crappy luck with it and my razr. Sometimes would work perfectly and sometimes radio wouldn't mute etc. I switched to a Blackberry 8830 and have had VERY few problems since. Most annoying problem has been intermittent feedback when I place a call that clears up in about a second or so.

Refdog
08-09-08, 05:21 PM
Thanks for the help. Looks like I will have to live with it at least until I get a different phone.

gnxs
08-21-08, 11:11 AM
I have had my 07 STS for about a month. It has the navigation system. When I am using my phone in Bluetooth mode I have a problem. If I dial out the radio mutes and I can hear on the Bluetooth.
However, if I receive an incoming call through my Bluetooth, the radio mutes when it rings, but as soon as I press the button to answer the phone the radio comes back on and it then can't be adjusted or muted manually. So, I can't hear anything over the Bluetooth.
I'm thinking that I have something set up wrong.
Any ideas?
Thanks.
I've only had my car a week (2006 STS-V), but I've noticed a similar problem. I have a Verizon Razr that works "almost" flawlessly. From what I've read here, it's one of the phones that syncs up well with the Bluetooth system in these cars. However, I'm not sure if it's a coincidence or not but the problem you describe only happens to me when I have the stereo cranked up. At normal volume the phone picks up and the radio will return when I hang up, but when it's really loud the radio will come back on right after I pick up the call and I can't hear the caller and need to hang up the call using the phone, turn down or turn off the radio and call them back.

I'm no electronics whiz, but perhaps the extra wattage from the amps running at high decibels causes interference with the bluetooth signal, who knows. I'm going to experiment with it some more to determine if it always happens when the stereo is cranked or if it was just a coincidence that it's happened to me three times now and all three I had the stereo blaring. Every other call worked fine and I never had the stereo loud at those times.......coincidence?

Force-1
08-21-08, 09:45 PM
I had the same problem with my STS, and upgrading the software on my phone corrected it. Sad that I had to learn this from Mazda (I have a CX-9), as they have a dedicated Bluetooth support team. They told me to take my phone to Sprint and upgrade the software, and that worked.

gnxs
08-21-08, 10:10 PM
I'm going to go to Verizon tomorrow and get it updated. I'll post about how effective it was. Thanks for the info.

ewill3rd
08-22-08, 07:19 AM
Updating the software in the phone and making sure you have the latest software update for the radio is about all you can do.
Not many dealers know how to do it, but I have had good results with the software update discs for the nav system.
There are a few posts on this software update.
I think they switched in mid '07 to the updated stuff in production.

Refdog
08-22-08, 04:04 PM
I will try that also. Hopefully, this will resolve the issue.
Thanks.