: Stability Control Won't Shut Off



rb1
08-07-08, 11:49 AM
I know how to turn TC off, turn Comp mode on, and turn SC off completely, but since I disconnected my battery and intalled a new wait4me PCM, my SC doesn't turn off. When i press the button once, tc shuts off, and when i press it again, it turns TC back on. One of my TPMs reads ---. Could this be it? I could have sworn it was reading --- for a long time and SC would shut off no problem. Anyone know about this? Also, is there any way to disable the TPMs to test this?

smoothq
08-07-08, 02:07 PM
That is exactly your problem. If the TPS reads 0 or --- it will not let you turn stability control off do to safety reasons. So A) it is a bad sensor... or B) It has lost connection with the brain and just needs to be reset at your local dealership. They will recheck everything and it is a warrenty issue so no worries good luck

rb1
08-07-08, 02:24 PM
No warranty though. They are all mixed up right now. I tried resetting them today, but it seems my right front is out and I can't get the horn to beep. Is there a way I can just unplug a fuse or something to disable the whole system? I have a HHTPG that works just fine.

smoothq
08-07-08, 03:14 PM
Are you out of factory warrenty..? If you are you can buy a new sensor for like $50 to $60 dallors. I had the same problem, Mine was damaged tho due to it coming off inside the wheel and they said that it wouldn't be covered due to that. Then another one went out with not coming lose and they covered that one. I ask then also about just turning off the whole tire pressure sensor thing and they said they had no way of doing that because it is required for our cars by Law because of how fast our cars are. They are also going to add it to every car in the near future for safety. But trust me it is definatly that sensor causing the traction control not to turn all the way off.

rb1
08-08-08, 09:42 AM
Thanks